summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-16 09:38:32 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-16 09:38:32 +0000
commitdd43199a38e76173699ea15f90450e0a2c40c91e (patch)
tree7d694be6261e3712509ed1420239a43f85aa6574 /media-gfx/darktable/files
parentBump for #394923 (diff)
downloadhistorical-dd43199a38e76173699ea15f90450e0a2c40c91e.tar.gz
historical-dd43199a38e76173699ea15f90450e0a2c40c91e.tar.bz2
historical-dd43199a38e76173699ea15f90450e0a2c40c91e.zip
Version bump (bug #408323).
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/darktable/files')
-rw-r--r--media-gfx/darktable/files/darktable-1.0-cflags.patch44
-rw-r--r--media-gfx/darktable/files/darktable-1.0-no-gphoto2.patch28
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/darktable/files/darktable-1.0-cflags.patch b/media-gfx/darktable/files/darktable-1.0-cflags.patch
new file mode 100644
index 000000000000..88841a04759f
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-1.0-cflags.patch
@@ -0,0 +1,44 @@
+--- darktable-1.0/src/CMakeLists.txt
++++ darktable-1.0/src/CMakeLists.txt
+@@ -233,40 +233,12 @@
+ # c++ code doesn't like -Werror (libraw)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fno-strict-aliasing")
+
+-if(NOT APPLE)
+- # apple build fails on deprecated warnings..
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
+-endif(NOT APPLE)
+-
+ if(NOT WIN32)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+ endif(NOT WIN32)
+
+-if(NOT BINARY_PACKAGE_BUILD)
+- MESSAGE("-- Checking for -march=native support")
+- CHECK_C_COMPILER_FLAG("-march=native" MARCHNATIVE)
+- if (MARCHNATIVE)
+- set(MARCH "-march=native")
+- else()
+- MESSAGE("-- Checking for -mtune=native support")
+- CHECK_C_COMPILER_FLAG("-mtune=native" MTUNENATIVE)
+- if (MTUNENATIVE)
+- set(MARCH "-mtune=native")
+- else()
+- set(MARCH "-mtune=generic")
+- endif()
+- endif()
+-else()
+- set(MARCH "-mtune=generic")
+-endif()
++set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG")
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse2 -mfpmath=sse -g")
+-set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -ffast-math -fexpensive-optimizations ${MARCH}")
+-set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -g -D_DEBUG")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2 -mfpmath=sse -g")
+-set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -ffast-math -fexpensive-optimizations ${MARCH}")
+-set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 -g -D_DEBUG")
+-
+
+ #
+ # Generate config.h
diff --git a/media-gfx/darktable/files/darktable-1.0-no-gphoto2.patch b/media-gfx/darktable/files/darktable-1.0-no-gphoto2.patch
new file mode 100644
index 000000000000..3ef088cbe273
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-1.0-no-gphoto2.patch
@@ -0,0 +1,28 @@
+--- darktable-1.0/src/libs/import.c
++++ darktable-1.0/src/libs/import.c
+@@ -28,13 +28,13 @@
+ #include "dtgtk/button.h"
+ #include "gui/accelerators.h"
+ #include "gui/gtk.h"
++#ifdef HAVE_GPHOTO2
+ #include "gui/camera_import_dialog.h"
++#endif
+ #include "libs/lib.h"
+
+ DT_MODULE(1)
+
+-// #ifdef HAVE_GPHOTO2
+-
+
+ #ifdef HAVE_GPHOTO2
+ /** helper function to update ui with available cameras and ther actionbuttons */
+@@ -44,7 +44,9 @@
+
+ typedef struct dt_lib_import_t
+ {
++#ifdef HAVE_GPHOTO2
+ dt_camctl_listener_t camctl_listener;
++#endif
+ GtkButton *import_file;
+ GtkButton *import_directory;
+ GtkButton *import_camera;