summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commit09a0cb6830d8c9cd82846bccece0d90c0bb30c8b (patch)
treecb24f3beb108accae6cf7aae333c349896d91687 /media-gfx/fbi
parentUpdate (diff)
downloadhistorical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.tar.gz
historical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.tar.bz2
historical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.zip
dependencie, fhs and use fixes
Diffstat (limited to 'media-gfx/fbi')
-rw-r--r--media-gfx/fbi/fbi-1.7.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/media-gfx/fbi/fbi-1.7.ebuild b/media-gfx/fbi/fbi-1.7.ebuild
index 9850446d0eec..566fa6c65352 100644
--- a/media-gfx/fbi/fbi-1.7.ebuild
+++ b/media-gfx/fbi/fbi-1.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ryan Tolboom <ryan@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbi/fbi-1.7.ebuild,v 1.1 2001/03/30 20:43:22 ryan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbi/fbi-1.7.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
A=fbi_1.7.tar.gz
S=${WORKDIR}/${P}
@@ -9,18 +9,27 @@ DESCRIPTION="fbi a framebuffer image viewer"
SRC_URI="http://www.strusel007.de/linux/misc/"${A}
HOMEPAGE="http://www.strusel007.de/linux/fbi.html"
-DEPEND=">=media-libs/jpeg-6b
- >=media-libs/netpbm-9.10"
+DEPEND=">=media-libs/jpeg-6b"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:$CFLAGS:" Makefile.orig > Makefile
+ cd ${S}/libpcd
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:$CFLAGS:" Makefile.orig > Makefile
+
+}
src_compile() {
- try make
+ try make
}
src_install() {
dodoc README
dobin src/fbi
- cp src/fbi.man fbi.1
- doman fbi.1
+ newman src/fbi.man fbi.1
}