summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-10-19 17:03:38 +0000
committerAron Griffis <agriffis@gentoo.org>2001-10-19 17:03:38 +0000
commit1edf9cf9a50d1ef6ace8344a47335b07bbce22e9 (patch)
tree725c9eabe6797018c1bcc91025c982261ef9c4d5 /media-gfx/graphviz
parentadded python error msg (diff)
downloadhistorical-1edf9cf9a50d1ef6ace8344a47335b07bbce22e9.tar.gz
historical-1edf9cf9a50d1ef6ace8344a47335b07bbce22e9.tar.bz2
historical-1edf9cf9a50d1ef6ace8344a47335b07bbce22e9.zip
Added ebuild for graphviz. Note that the tcl/tk stuff doesn't build
because it's looking for tclsh8.3. I assume configure.in just needs to be fixed up.
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.7.71
-rw-r--r--media-gfx/graphviz/graphviz-1.7.7.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.7.7 b/media-gfx/graphviz/files/digest-graphviz-1.7.7
new file mode 100644
index 000000000000..66ba8ca58ce3
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.7.7
@@ -0,0 +1 @@
+MD5 e04a6031b34d07ebceacc6ccb0745eb5 graphviz-1.7.7.tgz
diff --git a/media-gfx/graphviz/graphviz-1.7.7.ebuild b/media-gfx/graphviz/graphviz-1.7.7.ebuild
new file mode 100644
index 000000000000..9e1ed5e56fbc
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.7.7.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.7.7.ebuild,v 1.1 2001/10/19 17:03:38 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.research.att.com/sw/tools/graphviz/dist/$P.tgz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}