summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-06 14:42:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-06 14:42:59 +0000
commite6b7691865b4610d33b0283e95c4c6e4ed442bfd (patch)
tree7dbff7cce1b706541b6cce5d0ff3c6136671f340 /media-gfx/pydot/pydot-1.0.25.ebuild
parentRemove old versions. (diff)
downloadhistorical-e6b7691865b4610d33b0283e95c4c6e4ed442bfd.tar.gz
historical-e6b7691865b4610d33b0283e95c4c6e4ed442bfd.tar.bz2
historical-e6b7691865b4610d33b0283e95c4c6e4ed442bfd.zip
Version bump. Added python herd
Package-Manager: portage-2.1.10.10/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/pydot/pydot-1.0.25.ebuild')
-rw-r--r--media-gfx/pydot/pydot-1.0.25.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/pydot/pydot-1.0.25.ebuild b/media-gfx/pydot/pydot-1.0.25.ebuild
new file mode 100644
index 000000000000..d90beee84b36
--- /dev/null
+++ b/media-gfx/pydot/pydot-1.0.25.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pydot/pydot-1.0.25.ebuild,v 1.1 2011/08/06 14:42:59 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="http://code.google.com/p/pydot/ http://pypi.python.org/pypi/pydot"
+SRC_URI="http://pydot.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyparsing
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="dot_parser.py pydot.py"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-1.0.23-setup.patch
+}