summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-12-27 11:37:51 +0000
committerMart Raudsepp <leio@gentoo.org>2010-12-27 11:37:51 +0000
commit74a7a235ac94dacb721fad087c837deb1d57426e (patch)
treecded6d45d5dcaedcc790c7ca649f0f389c624702 /media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild
parentMark as stable. (diff)
downloadhistorical-74a7a235ac94dacb721fad087c837deb1d57426e.tar.gz
historical-74a7a235ac94dacb721fad087c837deb1d57426e.tar.bz2
historical-74a7a235ac94dacb721fad087c837deb1d57426e.zip
Version bump with the following most noteworthy upstream changes compared to 0.10.13: Many bugfixes to asfdemux, including for gentoo bug 321745. Assorted fixes to rmdemux (realmedia) and mpegaudioparse.
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild
new file mode 100644
index 000000000000..82f1e8e111e5
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild,v 1.1 2010/12/27 11:37:51 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.26
+ >=media-libs/gstreamer-0.10.26
+ >=dev-libs/glib-2.20"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.13"
+
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-ugly_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}