summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-25 00:04:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-25 00:04:07 +0000
commite2c71605bf1cd1d05abeb0514e7beb267cd7ee68 (patch)
tree306892d0c18ae9ea0b88550dca263b6fe8f061dd /media-libs/libjsw
parentAdd a patch to remove executable stacks, thanks to Martin von Gagern in bug #... (diff)
downloadhistorical-e2c71605bf1cd1d05abeb0514e7beb267cd7ee68.tar.gz
historical-e2c71605bf1cd1d05abeb0514e7beb267cd7ee68.tar.bz2
historical-e2c71605bf1cd1d05abeb0514e7beb267cd7ee68.zip
Move custom settings (CFLAGS/CXXFLAGS/LDFLAGS/etc...) to a build patch, include more headers, and fix building with newer versions of gcc #131045 by Thomas Hartman.
Package-Manager: portage-2.1_pre9-r4
Diffstat (limited to 'media-libs/libjsw')
-rw-r--r--media-libs/libjsw/ChangeLog12
-rw-r--r--media-libs/libjsw/files/digest-libjsw-1.5.52
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.5-build.patch114
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.5-gcc33.patch14
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.5-headers.patch9
-rw-r--r--media-libs/libjsw/libjsw-1.5.5.ebuild18
6 files changed, 156 insertions, 13 deletions
diff --git a/media-libs/libjsw/ChangeLog b/media-libs/libjsw/ChangeLog
index 110bbc48f574..61ead0d07629 100644
--- a/media-libs/libjsw/ChangeLog
+++ b/media-libs/libjsw/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libjsw
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.9 2005/06/03 00:49:16 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.10 2006/04/25 00:04:06 vapier Exp $
+
+ 25 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/libjsw-1.5.5-build.patch, files/libjsw-1.5.5-gcc33.patch,
+ +files/libjsw-1.5.5-headers.patch, -files/libjsw-1.5.5-liborder.patch,
+ libjsw-1.5.5.ebuild:
+ Move custom settings (CFLAGS/CXXFLAGS/LDFLAGS/etc...) to a build patch,
+ include more headers, and fix building with newer versions of gcc #131045 by
+ Thomas Hartman.
03 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+files/libjsw-1.5.5-liborder.patch, libjsw-1.5.5.ebuild:
diff --git a/media-libs/libjsw/files/digest-libjsw-1.5.5 b/media-libs/libjsw/files/digest-libjsw-1.5.5
index 9e302eac9423..fe5bec1674bd 100644
--- a/media-libs/libjsw/files/digest-libjsw-1.5.5
+++ b/media-libs/libjsw/files/digest-libjsw-1.5.5
@@ -1 +1,3 @@
MD5 10c3f3dd043bf5c095e9486dfe13edc3 libjsw-1.5.5.tar.bz2 317027
+RMD160 bb693cdba0adc527f9f16b106a1d01cc2062e574 libjsw-1.5.5.tar.bz2 317027
+SHA256 43f2cc14d9caf37645ec4f06ad7de2b9fc2515cd7fdaf6dff56563bd01744c5c libjsw-1.5.5.tar.bz2 317027
diff --git a/media-libs/libjsw/files/libjsw-1.5.5-build.patch b/media-libs/libjsw/files/libjsw-1.5.5-build.patch
new file mode 100644
index 000000000000..d29eb5c7ba6f
--- /dev/null
+++ b/media-libs/libjsw/files/libjsw-1.5.5-build.patch
@@ -0,0 +1,114 @@
+Search our custom $(LIB_DIRS) path before the stuff
+gtk-config injects in $(LIBS).
+
+http://bugs.gentoo.org/94867
+
+Make sure we respect CFLAGS / CXXFLAGS
+
+--- libjsw-1.5.5/jscalibrator/Makefile
++++ libjsw-1.5.5/jscalibrator/Makefile
+@@ -59,8 +59,6 @@
+ #CFLAGS = -Wall -O -g \
+ # `gtk-config --cflags`
+
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -funroll-loops -ffast-math \
+- `gtk-config --cflags`
+
+ CPPFLAGS = -D__cplusplus
+
+@@ -76,7 +74,7 @@
+ # to the LIB line depending on what you have set in the CFLAGS line
+ # farther above.
+ #
+-LIBS = -ljsw `gtk-config --libs`
++LIBS := -ljsw $(shell gtk-config --libs)
+
+ # Library Directories:
+ #
+@@ -85,7 +83,7 @@
+ # Each argument is of the format -L<dir> where <dir> is the full
+ # path to the directory.
+ #
+-LIB_DIRS =
++LIB_DIRS = -L../libjsw
+
+ # Header File Directories:
+ #
+@@ -95,7 +93,7 @@
+ # Each argument is of the format -I<dir> where <dir> is the full
+ # path to the directory.
+ #
+-INC_DIRS =
++INC_DIRS := $(shell gtk-config --cflags) -I../libjsw
+
+
+ # ########################################################################
+@@ -117,11 +115,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -130,10 +126,7 @@
+ $(BIN): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LDFLAGS) $(LIB_DIRS) $(LIBS)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
+--- libjsw-1.5.5/libjsw/Makefile
++++ libjsw-1.5.5/libjsw/Makefile
+@@ -51,11 +51,10 @@
+ # to debug the program.
+ #
+
+-CFLAGS = -Wall -O6 \
+- -fomit-frame-pointer -funroll-loops -ffast-math \
+- -finline-functions
++CFLAGS += -fPIC
++CXXFLAGS += -fPIC
+
+-CPPFLAGS = -D__cplusplus
++CPPFLAGS += -D__cplusplus
+
+
+ # ########################################################################
+@@ -83,11 +82,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC) $(CFLAGS)
++ $(CC) -c $*.c $(INC) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -96,10 +93,7 @@
+ $(LIB): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(LIB) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @-$(LS) $(LSFLAGS) $(LIB)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(LIB) $(LDFLAGS) $(LIBS) $(LIB_DIRS)
+
+ prebuild:
+ @echo "Building library \"$(LIB)\"..."
diff --git a/media-libs/libjsw/files/libjsw-1.5.5-gcc33.patch b/media-libs/libjsw/files/libjsw-1.5.5-gcc33.patch
index 37a46b3d218c..a7ae87607de5 100644
--- a/media-libs/libjsw/files/libjsw-1.5.5-gcc33.patch
+++ b/media-libs/libjsw/files/libjsw-1.5.5-gcc33.patch
@@ -30,3 +30,17 @@ http://bugs.gentoo.org/show_bug.cgi?id=85780
/*
* Checks if string pfx is a prefix of string s.
+--- libjsw/disk.cpp
++++ libjsw/disk.cpp
+@@ -131,11 +131,7 @@
+ return(0);
+
+ // Dan S: typecast is due to const.
+-#if defined(__cplusplus) || defined(c_plusplus)
+- while(ISBLANK(reinterpret_cast<char>(*path)))
+-#else
+ while(ISBLANK(*path))
+-#endif
+ path++;
+
+ return(*path == DIR_DELIMINATOR);
diff --git a/media-libs/libjsw/files/libjsw-1.5.5-headers.patch b/media-libs/libjsw/files/libjsw-1.5.5-headers.patch
new file mode 100644
index 000000000000..b7deed2a4c9f
--- /dev/null
+++ b/media-libs/libjsw/files/libjsw-1.5.5-headers.patch
@@ -0,0 +1,9 @@
+--- jscalibrator/jcwidgets.c
++++ jscalibrator/jcwidgets.c
+@@ -1,5 +1,6 @@
+ #include <jsw.h>
+ #include <gtk/gtk.h>
++#include <string.h>
+
+ #include "guiutils.h"
+ #include "jc.h"
diff --git a/media-libs/libjsw/libjsw-1.5.5.ebuild b/media-libs/libjsw/libjsw-1.5.5.ebuild
index ecd14b05fb50..61a7b3973136 100644
--- a/media-libs/libjsw/libjsw-1.5.5.ebuild
+++ b/media-libs/libjsw/libjsw-1.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/libjsw-1.5.5.ebuild,v 1.5 2005/06/03 00:49:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/libjsw-1.5.5.ebuild,v 1.6 2006/04/25 00:04:06 vapier Exp $
inherit eutils
@@ -18,26 +18,22 @@ DEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
epatch "${FILESDIR}"/${P}-gcc33.patch
bunzip2 libjsw/man/* jscalibrator/jscalibrator.1.bz2 || die "bunzip failed"
cd jscalibrator
epatch "${FILESDIR}"/${P}-gcc33.patch
- epatch "${FILESDIR}"/${P}-liborder.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
}
src_compile() {
cd "${S}"/libjsw
- emake CFLAGS="${CFLAGS} -fPIC" || die "main build failed"
- ln -s libjsw.so.${PV} libjsw.so
+ emake || die "main build failed"
+ #ln -s libjsw.so.${PV} libjsw.so
if use gtk ; then
cd "${S}"/jscalibrator
- ln -s ../include/jsw.h
- emake \
- CFLAGS="${CFLAGS}" \
- INC_DIRS="$(gtk-config --cflags) -I." \
- LIB_DIRS="-L../libjsw" \
- || die "jscalibrator failed"
+ emake || die "jscalibrator failed"
fi
}