summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-20 11:40:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-20 11:40:24 +0000
commit2709fbf9a6ff94b3b09b1077a8ad19129fd45020 (patch)
tree6f1950ec5dff9256a7c19d006df244b5f0bd1b18 /media-libs/schroedinger/schroedinger-1.0.5.ebuild
parentadd dev-util/pkgconfig to depend as per bug 232450 (diff)
downloadhistorical-2709fbf9a6ff94b3b09b1077a8ad19129fd45020.tar.gz
historical-2709fbf9a6ff94b3b09b1077a8ad19129fd45020.tar.bz2
historical-2709fbf9a6ff94b3b09b1077a8ad19129fd45020.zip
version bump
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25.7 x86_64
Diffstat (limited to 'media-libs/schroedinger/schroedinger-1.0.5.ebuild')
-rw-r--r--media-libs/schroedinger/schroedinger-1.0.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/schroedinger/schroedinger-1.0.5.ebuild b/media-libs/schroedinger/schroedinger-1.0.5.ebuild
new file mode 100644
index 000000000000..3ae6d7bdb2f1
--- /dev/null
+++ b/media-libs/schroedinger/schroedinger-1.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/schroedinger/schroedinger-1.0.5.ebuild,v 1.1 2008/07/20 11:40:24 aballier Exp $
+
+DESCRIPTION="C-based libraries and GStreamer plugins for the Dirac video codec"
+HOMEPAGE="http://www.diracvideo.org"
+SRC_URI="http://www.diracvideo.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gstreamer"
+
+RDEPEND=">=dev-libs/liboil-0.3.15
+ gstreamer? ( >=media-libs/gst-plugins-base-0.10.12 )"
+# Doesn't seem to build as of 1.0.5
+# opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ $(use_enable gstreamer)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS NEWS TODO
+}