summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 01:11:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 01:11:31 +0000
commitf912e831021f289ce47fde591f79b6c608574c2a (patch)
treec9e65fb103e185c93b3e5c0fb773b0036f33a036 /media-libs/smpeg
parentversion bump (diff)
downloadhistorical-f912e831021f289ce47fde591f79b6c608574c2a.tar.gz
historical-f912e831021f289ce47fde591f79b6c608574c2a.tar.bz2
historical-f912e831021f289ce47fde591f79b6c608574c2a.zip
Fix building with gcc-4.1.x #113558 by Robert Marmorstein.
Package-Manager: portage-2.0.53
Diffstat (limited to 'media-libs/smpeg')
-rw-r--r--media-libs/smpeg/ChangeLog6
-rw-r--r--media-libs/smpeg/Manifest17
-rw-r--r--media-libs/smpeg/files/smpeg-0.4.4-gcc41.patch41
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r7.ebuild3
4 files changed, 62 insertions, 5 deletions
diff --git a/media-libs/smpeg/ChangeLog b/media-libs/smpeg/ChangeLog
index 272428993cd1..98b087a26036 100644
--- a/media-libs/smpeg/ChangeLog
+++ b/media-libs/smpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/smpeg
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/ChangeLog,v 1.25 2005/12/13 15:49:22 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/ChangeLog,v 1.26 2005/12/17 01:11:31 vapier Exp $
+
+ 17 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/smpeg-0.4.4-gcc41.patch, smpeg-0.4.4-r7.ebuild:
+ Fix building with gcc-4.1.x #113558 by Robert Marmorstein.
13 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
smpeg-0.4.4-r7.ebuild:
diff --git a/media-libs/smpeg/Manifest b/media-libs/smpeg/Manifest
index 3adee9cbce6b..03a38e744278 100644
--- a/media-libs/smpeg/Manifest
+++ b/media-libs/smpeg/Manifest
@@ -1,10 +1,21 @@
-MD5 d9321b06b5117da7ba38df10a78b890e ChangeLog 3747
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 548a306dd5320b3022c6aa7d4992a9bd ChangeLog 3913
MD5 228adf6a40bb4eef222c38d23f97014b files/digest-smpeg-0.4.4-r6 63
MD5 228adf6a40bb4eef222c38d23f97014b files/digest-smpeg-0.4.4-r7 63
MD5 3ab2c17a1fa8a3c293ec83d7f4d45515 files/smpeg-0.4.4-PIC.patch 9472
MD5 f70fffdbc4af6ca684817ede925c6087 files/smpeg-0.4.4-config.patch 472
+MD5 8b979a58307d7196655758bd3d2466c4 files/smpeg-0.4.4-gcc41.patch 1390
MD5 7d1d2f2e55e8d98f7d62dcbb680cec7d files/smpeg-0.4.4-gnu-stack.patch 955
MD5 dcc2db7c8aa509096fc557b99bd35490 files/smpeg-0.4.4-m4.patch 233
-MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 b06aefcfd7c56746451214c6a0c6bf8b smpeg-0.4.4-r6.ebuild 1530
-MD5 e9463bf7c6b0101cdb44c017b02483ca smpeg-0.4.4-r7.ebuild 1600
+MD5 fd577d7f2d35385ff4bee413c0f7852c smpeg-0.4.4-r7.ebuild 1636
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDo2Xh2+ySkm8kpY0RArwjAJ9wCzaeiA8lagz9kS/Bb0uX8Aa9SACgrfzC
+byOIWLJEncNcoxDFDq5uPjo=
+=M1H2
+-----END PGP SIGNATURE-----
diff --git a/media-libs/smpeg/files/smpeg-0.4.4-gcc41.patch b/media-libs/smpeg/files/smpeg-0.4.4-gcc41.patch
new file mode 100644
index 000000000000..4a0eeb4530ae
--- /dev/null
+++ b/media-libs/smpeg/files/smpeg-0.4.4-gcc41.patch
@@ -0,0 +1,41 @@
+Index: MPEGaudio.h
+===================================================================
+RCS file: /cvs/cvsroot/smpeg/MPEGaudio.h,v
+retrieving revision 1.23
+diff -u -p -r1.23 MPEGaudio.h
+--- smpeg/MPEGaudio.h 17 Jul 2001 19:52:24 -0000 1.23
++++ smpeg/MPEGaudio.h 6 Dec 2005 06:10:43 -0000
+@@ -151,12 +151,6 @@ private:
+ /* The actual MPEG audio class */
+ class MPEGaudio : public MPEGerror, public MPEGaudioaction {
+
+- friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
+- friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
+-#ifdef THREADED_AUDIO
+- friend int Decode_MPEGaudio(void *udata);
+-#endif
+-
+ public:
+ MPEGaudio(MPEGstream *stream, bool initSDL = true);
+ virtual ~MPEGaudio();
+@@ -367,6 +361,20 @@ public:
+ #define N_TIMESTAMPS 5
+
+ double timestamp[N_TIMESTAMPS];
++
++ /* Functions which access MPEGaudio internals */
++ friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
++ friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
++#ifdef THREADED_AUDIO
++ friend int Decode_MPEGaudio(void *udata);
++#endif
+ };
+
++/* Need to duplicate the prototypes, this is not a typo :) */
++void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
++int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
++#ifdef THREADED_AUDIO
++int Decode_MPEGaudio(void *udata);
++#endif
++
+ #endif /* _MPEGAUDIO_H_ */
diff --git a/media-libs/smpeg/smpeg-0.4.4-r7.ebuild b/media-libs/smpeg/smpeg-0.4.4-r7.ebuild
index 32355ced848e..01a752a885d7 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r7.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r7.ebuild,v 1.2 2005/12/13 15:49:22 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r7.ebuild,v 1.3 2005/12/17 01:11:31 vapier Exp $
inherit eutils toolchain-funcs
@@ -25,6 +25,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-gnu-stack.patch
epatch "${FILESDIR}"/${P}-config.patch
epatch "${FILESDIR}"/${P}-PIC.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
# Bundled libtool doesnt properly add C++ libs even
# though the shared library includes C++ objects
sed -i \