summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-30 02:55:53 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-30 02:55:53 +0000
commit7f616d8aece045aa016148d7ec8cba53aee29708 (patch)
tree03057769059b887b93e524ff16dc8d3f83ebea4c /media-libs
parentuse econf (diff)
downloadhistorical-7f616d8aece045aa016148d7ec8cba53aee29708.tar.gz
historical-7f616d8aece045aa016148d7ec8cba53aee29708.tar.bz2
historical-7f616d8aece045aa016148d7ec8cba53aee29708.zip
hppa stable
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmikmod/libmikmod-3.1.11.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/media-libs/libmikmod/libmikmod-3.1.11.ebuild b/media-libs/libmikmod/libmikmod-3.1.11.ebuild
index d978ec9edb80..4e6943387952 100644
--- a/media-libs/libmikmod/libmikmod-3.1.11.ebuild
+++ b/media-libs/libmikmod/libmikmod-3.1.11.ebuild
@@ -1,33 +1,31 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.1.11.ebuild,v 1.1 2004/03/26 17:13:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.1.11.ebuild,v 1.2 2004/03/30 02:55:53 vapier Exp $
-inherit gnuconfig
-inherit flag-o-matic
-
-IUSE="oss esd alsa"
+inherit gnuconfig flag-o-matic
DESCRIPTION="A library to play a wide range of module formats"
HOMEPAGE="http://mikmod.raphnet.net/"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+SRC_URI="http://mikmod.raphnet.net/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 | LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 hppa ~sparc ~mips ~alpha ia64"
+IUSE="oss esd alsa"
DEPEND=">=media-libs/audiofile-0.2.3
alsa? ( >=media-libs/alsa-lib-0.5.9 )
esd? ( >=media-sound/esound-0.2.19 )"
-SLOT="0"
-LICENSE="LGPL-2.1 | LGPL-2"
-KEYWORDS="~x86 ~amd64 ~hppa ~sparc ~mips ~alpha ia64"
-
src_compile() {
filter-flags -Os
local myconf
myconf="--enable-af" # include AudioFile driver
- [ -z `use esd` ] || myconf="${myconf} --enable-esd"
- [ -z `use alsa` ] || myconf="${myconf} --enable-alsa"
- [ -z `use oss` ] || myconf="${myconf} --enable-oss"
+ use esd && myconf="${myconf} --enable-esd"
+ use alsa && myconf="${myconf} --enable-alsa"
+ use oss && myconf="${myconf} --enable-oss"
# alpha, amd64 and ia64 (at least) need gnuconfig_update
gnuconfig_update
@@ -37,9 +35,8 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING* NEWS README TODO
+ dodoc AUTHORS NEWS README TODO
dohtml docs/*.html
}