summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2007-09-17 22:56:35 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2007-09-17 22:56:35 +0000
commitd552b4e932ed5d752d7e92feb5dc84cce275c451 (patch)
treedece3af8fabf2edc3ce1216c03c07dd0a3c1253d /media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild
parentVersion bump which fixes mercurical bug #186445 (diff)
downloadhistorical-d552b4e932ed5d752d7e92feb5dc84cce275c451.tar.gz
historical-d552b4e932ed5d752d7e92feb5dc84cce275c451.tar.bz2
historical-d552b4e932ed5d752d7e92feb5dc84cce275c451.zip
fixed bug #192396, parameter changing vof to vf; thanks to C.Mueller for reporting this; metadata fixed
Package-Manager: portage-2.1.2.12
Diffstat (limited to 'media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild')
-rw-r--r--media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild b/media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild
new file mode 100644
index 000000000000..0bac075df56f
--- /dev/null
+++ b/media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-vdrrip/vdr-vdrrip-0.3.0-r7.ebuild,v 1.1 2007/09/17 22:56:35 hd_brummy Exp $
+
+inherit vdr-plugin eutils
+
+DESCRIPTION="VDR plugin: convert video-recordings to mpeg4 for burning on CDs"
+HOMEPAGE="http://www.a-land.de/"
+SRC_URI="http://www.a-land.de/${P}.tgz
+ http://www.a-land.de/queuehandler-fixed-0.3.0.sh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.0"
+RDEPEND="${DEPEND}
+ >=media-video/mplayer-1.0_pre8
+ sys-process/procps
+ sys-apps/util-linux"
+# media-video/vdrsync seems to be optional
+
+src_unpack() {
+ vdr-plugin_src_unpack
+ cp ${DISTDIR}/queuehandler-fixed-0.3.0.sh ${S}/scripts/queuehandler.sh
+
+ if
+ has_version ">=media-video/vdr-1.3.7" ;
+ then
+ elog "applying VDR > 1.3.6 patch"
+ epatch ${FILESDIR}/vdrrip-0.3.0-1.3.7.diff
+ epatch ${FILESDIR}/maketempdir.diff
+ epatch ${FILESDIR}/greppid2.diff
+ epatch ${FILESDIR}/detectlength.diff
+ epatch ${FILESDIR}/fix-ogm-ac3-vdrsync-dev.diff
+ epatch ${FILESDIR}/fixpreview.diff
+ epatch ${FILESDIR}/mencoderparam-2.diff
+ epatch ${FILESDIR}/preserve-queue-owner.diff
+ epatch ${FILESDIR}/log-patch.diff
+ epatch ${FILESDIR}/vdr-vdrrip-0.3.0-mplayercmd2.diff
+
+ #minipatch -vop -> -vf mencoder option bug #192396
+ sed -e 's,-vop,-vf,' -i ${S}/scripts/queuehandler.sh
+ sed -e 's,-vop,-vf,' -i ${S}/movie.c
+ fi
+
+ elog "Patching queuehandler.sh.conf for gentoo-needs..."
+ cd ${S}
+ sed -e "s,/usr/local/bin/,/usr/bin/," \
+ -e 's,/usr/bin/mencoder_ac3,/usr/bin/mencoder,' \
+ -e 's,/usr/bin/mplayer_ac3,/usr/bin/mplayer,' \
+ -i scripts/queuehandler.sh.conf
+
+ sed -e 's,scriptdir=`dirname $0`,scriptdir=/etc/vdr/plugins/vdrrip,' \
+ -e 's,nice -+19,nice -n 19,' \
+ -i scripts/queuehandler.sh
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ # save config files
+ insinto /etc/vdr/plugins/vdrrip
+ newins scripts/queuehandler.sh.conf vdrrip-qh.conf
+ newconfd ${FILESDIR}/vdrrip-qh.conf vdrrip-qh
+ # add start script
+ doinitd ${FILESDIR}/vdrrip-qh
+ # save in bin
+ newbin scripts/queuehandler.sh vdrrip-qh
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ elog "You should have a look at this files:"
+ elog
+ elog "* /etc/vdr/plugins/vdrrip/vdrrip-qh.conf"
+ elog
+ elog "Use vdrrip-qh to start the vdrrip queue handler."
+ elog "You can also run 'rc-update add /etc/init.d/vdrrip-qh default' to"
+ elog "let vdrrip-qh start automaticly when the system starts."
+
+ elog
+ elog "If you used vdrrip before, mind that it runs by default as user vdr now."
+ elog "To correct the permissions you should execute this:"
+ elog "# chown vdr:vdr -R /var/log/vdrrip-qh /tmp/vdrrip /tmp/queuehandler.vdr"
+ elog
+}