summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Romans <killsoft@gentoo.org>2004-07-22 05:02:03 +0000
committerRob Romans <killsoft@gentoo.org>2004-07-22 05:02:03 +0000
commit49ab294e0405b217770f499dc1460588b4509390 (patch)
treeb7a331bb71720814d8d1656cd32add9f22e3eb5b /media-radio/tlf
parentstable on amd64 (diff)
downloadhistorical-49ab294e0405b217770f499dc1460588b4509390.tar.gz
historical-49ab294e0405b217770f499dc1460588b4509390.tar.bz2
historical-49ab294e0405b217770f499dc1460588b4509390.zip
create ebuild for new upstream version
Diffstat (limited to 'media-radio/tlf')
-rw-r--r--media-radio/tlf/ChangeLog7
-rw-r--r--media-radio/tlf/Manifest4
-rw-r--r--media-radio/tlf/files/digest-tlf-0.9.201
-rw-r--r--media-radio/tlf/tlf-0.9.20.ebuild31
4 files changed, 41 insertions, 2 deletions
diff --git a/media-radio/tlf/ChangeLog b/media-radio/tlf/ChangeLog
index 3f4dc958148e..1f257ba450c2 100644
--- a/media-radio/tlf/ChangeLog
+++ b/media-radio/tlf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/tlf
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tlf/ChangeLog,v 1.3 2004/06/30 02:40:00 killsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tlf/ChangeLog,v 1.4 2004/07/22 05:02:03 killsoft Exp $
+
+*tlf-0.9.20 (22 Jul 2004)
+
+ 22 Jul 2004; Robb Romans <killsoft@gentoo.org> +tlf-0.9.20.ebuild:
+ Add ebuild for new version.
29 Jun 2004; Robb Romans <killsoft@gentoo.org> tlf-0.9.19.ebuild:
Move to virtual/libc
diff --git a/media-radio/tlf/Manifest b/media-radio/tlf/Manifest
index a3659106407a..ce32c915c373 100644
--- a/media-radio/tlf/Manifest
+++ b/media-radio/tlf/Manifest
@@ -1,4 +1,6 @@
+MD5 0445add4bc1f43c112c7919a487f02ef tlf-0.9.20.ebuild 745
MD5 7d49d939703b2f67e549b58f81b78531 tlf-0.9.19.ebuild 738
-MD5 2254991ac0563676dc7b04c5f3927596 ChangeLog 511
+MD5 3fc5f59c1fb309cd8289bba3121a97fa ChangeLog 638
MD5 28d0c3bb6c80425620241cff231da8d3 metadata.xml 224
MD5 c0e39249a77a318de45e2dbcf775a9f6 files/digest-tlf-0.9.19 62
+MD5 16c4bb832d86bf9c3928b9ca48da860d files/digest-tlf-0.9.20 62
diff --git a/media-radio/tlf/files/digest-tlf-0.9.20 b/media-radio/tlf/files/digest-tlf-0.9.20
new file mode 100644
index 000000000000..859d8abc9110
--- /dev/null
+++ b/media-radio/tlf/files/digest-tlf-0.9.20
@@ -0,0 +1 @@
+MD5 8f890b0349f512c55c22430eaca5c9a4 tlf-0.9.20.tar.gz 357207
diff --git a/media-radio/tlf/tlf-0.9.20.ebuild b/media-radio/tlf/tlf-0.9.20.ebuild
new file mode 100644
index 000000000000..a62783e881c1
--- /dev/null
+++ b/media-radio/tlf/tlf-0.9.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tlf/tlf-0.9.20.ebuild,v 1.1 2004/07/22 05:02:03 killsoft Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+RDEPEND="virtual/libc
+ sys-libs/ncurses
+ media-libs/hamlib"
+
+DEPEND="sys-apps/gawk"
+
+src_compile() {
+ append-flags -L/usr/lib/hamlib
+ econf --enable-hamlib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+}