summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-14 13:52:55 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-14 13:52:55 +0000
commit8ca5918eccdc84071b682384e392fa67d41e9e14 (patch)
tree1766a1594139855816ca68b825dc0b4a9357b276 /media-sound/alsa-headers/alsa-headers-1.0.8.ebuild
parentAdded virtual/os-headers to DEPEND. It was missing and as such util-linux wa... (diff)
downloadhistorical-8ca5918eccdc84071b682384e392fa67d41e9e14.tar.gz
historical-8ca5918eccdc84071b682384e392fa67d41e9e14.tar.bz2
historical-8ca5918eccdc84071b682384e392fa67d41e9e14.zip
Version bump.
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'media-sound/alsa-headers/alsa-headers-1.0.8.ebuild')
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.8.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.8.ebuild
new file mode 100644
index 000000000000..bccb574de2e0
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.8.ebuild,v 1.1 2005/01/14 13:52:07 eradicator Exp $
+
+IUSE=""
+
+inherit eutils
+
+MY_PV="${PV/_rc/rc}"
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+MY_FILESDIR="${FILESDIR/headers/driver}"
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=""
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+ if [ -L /usr/include/sound ]; then
+ rm /usr/include/sound
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.0.6a-user.patch
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ cd ${S}/alsa-kernel/include
+ insinto /usr/include/sound
+ doins *.h
+}