summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-26 19:33:14 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-26 19:33:14 +0000
commitec34068212114c75ce818004f99477eba732be8c (patch)
tree38615d982ee3c959dac7024cda1ba0adea684fbd /media-sound/alsaplayer
parentlibtoolize (diff)
downloadhistorical-ec34068212114c75ce818004f99477eba732be8c.tar.gz
historical-ec34068212114c75ce818004f99477eba732be8c.tar.bz2
historical-ec34068212114c75ce818004f99477eba732be8c.zip
new media player
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/ChangeLog10
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.59.ebuild61
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.591
3 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
new file mode 100644
index 000000000000..7ad1ce1465d0
--- /dev/null
+++ b/media-sound/alsaplayer/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/alsaplayer
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.1 2002/04/26 19:33:14 seemant Exp $
+
+*alsaplayer-0.99.59 (26 Apr 2002)
+
+ 26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> alsaplayer-0.99.59.ebuild
+ files/digest-alsaplayer-0.99.59
+
+ Music player which uses ALSA primarily
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild
new file mode 100644
index 000000000000..d608ef376070
--- /dev/null
+++ b/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Seemant Kulleen <seemant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild,v 1.1 2002/04/26 19:33:14 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Media player primarily utilising ALSA"
+SRC_URI="http://www.alsaplayer.org/${P}.tar.bz2"
+HOMEPAGE="http://www.alsa-project.org/"
+QTROOT="/usr/qt/3"
+
+DEPEND=">=media-libs/alsa-lib-0.5.10
+ qt? ( >=x11-libs/qt-3.0.1 )
+ esd? ( media-sound/esound )
+ gtk? ( x11-libs/gtk+ )
+ oggvorbis? ( media-libs/libvorbis )
+ >=media-libs/libmikmod-3.1.10
+ >=dev-libs/glib-1.2.10"
+
+
+src_compile() {
+
+ local myconf
+
+ use oggvorbis \
+ || myconf="--enable-vorbis=no"
+
+ use oss \
+ || myconf="${myconf} --enable-oss=no"
+
+ use esd \
+ && myconf="${myconf} --enable-audiofile=yes" \
+ || myconf="${myconf} --enable-esd=no"
+
+ use nas \
+ && myconf="${myconf} --enable-nas=yes"
+
+ use gtk \
+ || myconf="${myconf} --enable-gtk=no"
+
+ use qt \
+ && myconf="${myconf} --enable-qt=yes \
+ --with-qt-libdir=${QTROOT}/lib \
+ --with-qt-indir=${QTROOT}/include \
+ --with-qt-bindir=${QTROOT}/bin"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+ dodoc docs/sockmon.txt docs/wishlist.txt
+}
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59
new file mode 100644
index 000000000000..540b702244f6
--- /dev/null
+++ b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59
@@ -0,0 +1 @@
+MD5 1e8a729f7eb415224e68b06e701dbaef alsaplayer-0.99.59.tar.bz2 561990