summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-09 18:45:44 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-09 18:45:44 +0000
commit469f6f1d8fe6a0c94e7420ddda2a27f7ae152f87 (patch)
treed0300528b4aefbe08d8f2c220a239aac0c6abd37 /media-sound/audacity
parentfix bugs and patchs (diff)
downloadhistorical-469f6f1d8fe6a0c94e7420ddda2a27f7ae152f87.tar.gz
historical-469f6f1d8fe6a0c94e7420ddda2a27f7ae152f87.tar.bz2
historical-469f6f1d8fe6a0c94e7420ddda2a27f7ae152f87.zip
Updated ebuild with a patch to allow >=gcc3 systems to compile properly.
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/audacity-1.0.0-r1.ebuild49
-rw-r--r--media-sound/audacity/audacity-1.0.0.ebuild6
-rw-r--r--media-sound/audacity/files/audacity-1.0.0-gcc31.patch70
-rw-r--r--media-sound/audacity/files/digest-audacity-1.0.0-r11
5 files changed, 130 insertions, 4 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index ec145f36e3ed..51225dfb38e6 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.1 2002/06/21 23:07:25 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.2 2002/08/09 18:45:44 raker Exp $
+
+*audacity-1.0.0-r1 (09 Aug 2002)
+
+ 09 Aug 2002; Nick Hadaway <raker@gentoo.org> audacity-1.0.0-r1.ebuild,
+ files/digest-audacity-1.0.0-r1, files/audacity-1.0.0-gcc31.patch :
+ Updated ebuild with a patch to allow >=gcc3 systems to compile properly.
*audacity-1.0.0 (21 Jun 2002)
diff --git a/media-sound/audacity/audacity-1.0.0-r1.ebuild b/media-sound/audacity/audacity-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..c83a86a61331
--- /dev/null
+++ b/media-sound/audacity/audacity-1.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0-r1.ebuild,v 1.1 2002/08/09 18:45:44 raker Exp $
+
+DESCRIPTION="A free, crossplatform audio editor."
+SRC_URI="mirror://sourceforge/audacity/audacity-src-1.0.0.tgz"
+HOMEPAGE="http://audacity.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+# doesn't compile with wxGTK-2.3.2
+DEPEND="~x11-libs/wxGTK-2.2.9
+ oggvorbis? ( media-libs/libvorbis )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Only patch if using gcc 3.x
+ if [ "`eval echo \`gcc -dumpversion\` | cut -f1 -d.`" -eq 3 ]
+ then
+ cd ${WORKDIR}/audacity-src-${PV}
+ patch -p1 <${FILESDIR}/${P}-gcc31.patch || die
+ fi
+}
+
+src_compile() {
+ local myconf
+ myconf="--with-id3"
+ use oggvorbis && myconf="${myconf} --with-vorbis"
+
+ # arts is broken! :(
+ # use arts && myconf="${myconf} --with-arts-soundserver"
+
+ cd ${WORKDIR}/audacity-src-1.0.0
+ ./configure --prefix=/usr $myconf || die
+
+ make || die
+}
+
+src_install () {
+ cd ${WORKDIR}/audacity-src-1.0.0
+
+ export PREFIX=${D}/usr
+ make -e install || die
+}
+
diff --git a/media-sound/audacity/audacity-1.0.0.ebuild b/media-sound/audacity/audacity-1.0.0.ebuild
index 1d4c4d9e4dc2..baffacef02e2 100644
--- a/media-sound/audacity/audacity-1.0.0.ebuild
+++ b/media-sound/audacity/audacity-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0.ebuild,v 1.5 2002/07/19 12:27:52 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0.ebuild,v 1.6 2002/08/09 18:45:44 raker Exp $
DESCRIPTION="A free, crossplatform audio editor."
SRC_URI="mirror://sourceforge/audacity/audacity-src-1.0.0.tgz"
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
KEYWORDS="x86"
# doesn't compile with wxGTK-2.3.2
-DEPEND="=x11-libs/wxGTK-2.2.9
+DEPEND="~x11-libs/wxGTK-2.2.9
oggvorbis? ( media-libs/libvorbis )"
src_compile() {
@@ -25,7 +25,7 @@ src_compile() {
cd ${WORKDIR}/audacity-src-1.0.0
./configure --prefix=/usr $myconf || die
- emake || die
+ make || die
}
src_install () {
diff --git a/media-sound/audacity/files/audacity-1.0.0-gcc31.patch b/media-sound/audacity/files/audacity-1.0.0-gcc31.patch
new file mode 100644
index 000000000000..9cf3d3689fba
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.0.0-gcc31.patch
@@ -0,0 +1,70 @@
+diff -u -r audacity-src-1.0.0.old/id3lib/src/tag_file.cpp audacity-src-1.0.0/id3lib/src/tag_file.cpp
+--- audacity-src-1.0.0.old/id3lib/src/tag_file.cpp 2002-06-05 09:51:19.000000000 +0200
++++ audacity-src-1.0.0/id3lib/src/tag_file.cpp 2002-07-26 21:00:16.000000000 +0200
+@@ -281,7 +281,7 @@
+ //ID3_THROW_DESC(ID3E_NoFile, "couldn't open temp file");
+ }
+
+- ofstream tmpOut(fd);
++ ofstream tmpOut(sTempFile);
+ if (!tmpOut)
+ {
+ tmpOut.close();
+@@ -293,7 +293,7 @@
+
+ tmpOut.write(tagData, tagSize);
+ file.seekg(tag.GetPrependedBytes(), ios::beg);
+- uchar tmpBuffer[BUFSIZ];
++ char tmpBuffer[BUFSIZ];
+ while (file)
+ {
+ file.read(tmpBuffer, BUFSIZ);
+diff -u -r audacity-src-1.0.0.old/id3lib/src/utils.cpp audacity-src-1.0.0/id3lib/src/utils.cpp
+--- audacity-src-1.0.0.old/id3lib/src/utils.cpp 2002-06-05 09:51:19.000000000 +0200
++++ audacity-src-1.0.0/id3lib/src/utils.cpp 2002-07-26 21:01:25.000000000 +0200
+@@ -40,7 +40,8 @@
+ #define NOCREATE ((std::ios_base::openmode)0)
+ #define toascii(X) (X)
+ #else
+-#define NOCREATE ios::nocreate
++//#define NOCREATE ios::nocreate
++#define NOCREATE ios::in
+ #endif
+
+ #include "utils.h"
+@@ -106,7 +107,7 @@
+ size_t source_size = source.size();
+ // const char* source_str = source.data();
+ char * source_str = new char[source.length()+1];
+- source.copy(source_str, string::npos);
++ source.copy(source_str, String::npos);
+ source_str[source.length()] = 0;
+
+ #define BUFSIZ 1024
+@@ -242,7 +243,7 @@
+ size_t size = 0;
+ if (file.is_open())
+ {
+- streamoff curpos = file.tellg();
++ int curpos = file.tellg();
+ file.seekg(0, ios::end);
+ size = file.tellg();
+ file.seekg(curpos);
+@@ -255,7 +256,7 @@
+ size_t size = 0;
+ if (file.is_open())
+ {
+- streamoff curpos = file.tellg();
++ int curpos = file.tellg();
+ file.seekg(0, ios::end);
+ size = file.tellg();
+ file.seekg(curpos);
+@@ -268,7 +269,7 @@
+ size_t size = 0;
+ if (file.is_open())
+ {
+- streamoff curpos = file.tellp();
++ int curpos = file.tellp();
+ file.seekp(0, ios::end);
+ size = file.tellp();
+ file.seekp(curpos);
diff --git a/media-sound/audacity/files/digest-audacity-1.0.0-r1 b/media-sound/audacity/files/digest-audacity-1.0.0-r1
new file mode 100644
index 000000000000..380cf1d78a80
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.0.0-r1
@@ -0,0 +1 @@
+MD5 6711813f16c3d64e63209cb355191af6 audacity-src-1.0.0.tgz 1699883