summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2004-03-31 10:14:35 +0000
committerJoshua Brindle <method@gentoo.org>2004-03-31 10:14:35 +0000
commit1013f2af338b66e1e9e776b504fe667b0ee42c6c (patch)
tree4095d4a9a31e99e8fe5478969a203f492feb401b /media-sound/audio-entropyd
parentNew upstream version. Closes 46032. (diff)
downloadhistorical-1013f2af338b66e1e9e776b504fe667b0ee42c6c.tar.gz
historical-1013f2af338b66e1e9e776b504fe667b0ee42c6c.tar.bz2
historical-1013f2af338b66e1e9e776b504fe667b0ee42c6c.zip
better ebuild/init file
Diffstat (limited to 'media-sound/audio-entropyd')
-rw-r--r--media-sound/audio-entropyd/ChangeLog6
-rw-r--r--media-sound/audio-entropyd/Manifest6
-rw-r--r--media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild24
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd.init24
4 files changed, 41 insertions, 19 deletions
diff --git a/media-sound/audio-entropyd/ChangeLog b/media-sound/audio-entropyd/ChangeLog
index 5ac63036da7a..ab96ea46a219 100644
--- a/media-sound/audio-entropyd/ChangeLog
+++ b/media-sound/audio-entropyd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audio-entropyd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.1 2004/03/31 09:58:00 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.2 2004/03/31 10:14:35 method Exp $
+
+ 31 Mar 2004; Joshua Brindle <method@gentoo.org> audio-entropyd-0.0.6.ebuild,
+ files/audio-entropyd.init:
+ updated init file and ebuild courtesy of Cory Visi <cory@visi.name>
*audio-entropyd-0.0.6 (31 Mar 2004)
diff --git a/media-sound/audio-entropyd/Manifest b/media-sound/audio-entropyd/Manifest
index 6f31eb212941..17555568f8a0 100644
--- a/media-sound/audio-entropyd/Manifest
+++ b/media-sound/audio-entropyd/Manifest
@@ -1,5 +1,5 @@
MD5 96e29d7bb8e68a4c9e642e3b4029f762 metadata.xml 325
-MD5 05e317e850707662727c376cac1dc032 audio-entropyd-0.0.6.ebuild 671
-MD5 ec2759397e4134e0692607a8cb40dda6 ChangeLog 411
+MD5 55fbbfb202d213007cc0eb947b675992 audio-entropyd-0.0.6.ebuild 823
+MD5 963521ade0f0fa844e93ef03dbc252cf ChangeLog 590
MD5 0585a52027bab216bab4009edb0dd4e4 files/digest-audio-entropyd-0.0.6 68
-MD5 385513af351f6d15cf7276ce5539c267 files/audio-entropyd.init 501
+MD5 2757f0e52154501b6667de60d04be131 files/audio-entropyd.init 666
diff --git a/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild b/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
index 12249b004a88..77923d8d1037 100644
--- a/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
+++ b/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild,v 1.1 2004/03/31 09:58:00 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild,v 1.2 2004/03/31 10:14:35 method Exp $
DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device."
HOMEPAGE="http://www.vanheusden.com/aed/"
@@ -9,17 +9,29 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ >=sys-apps/sed-4"
S=${WORKDIR}/${P}
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i.orig \
+ -e "s:^OPT_FLAGS=.*:OPT_FLAGS=$CFLAGS:" \
+ Makefile
+}
+
src_compile() {
emake || die "emake failed"
}
src_install() {
- dobin audio-entropyd
- exeinto /etc/init.d
- newexe ${FILESDIR}/audio-entropyd.init audio-entropyd
+ dosbin audio-entropyd
+
+ insinto /etc/init.d
+ insopts -m0755
+ newins ${FILESDIR}/${PN}.init ${PN}
}
diff --git a/media-sound/audio-entropyd/files/audio-entropyd.init b/media-sound/audio-entropyd/files/audio-entropyd.init
index a4c56fc6df15..dacf5debb37e 100644
--- a/media-sound/audio-entropyd/files/audio-entropyd.init
+++ b/media-sound/audio-entropyd/files/audio-entropyd.init
@@ -1,19 +1,25 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.init,v 1.1 2004/03/31 09:58:00 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.init,v 1.2 2004/03/31 10:14:35 method Exp $
-start() {
+depend() {
+ need modules
+ use alsa
+}
- ebegin "audio-entropyd"
- start-stop-daemon --start --quiet --exec /usr/bin/audio-entropyd --background
- eend $?
+start() {
+ local params=""
+ [ -n "$DEVICE" ] && params="$params -d $DEVICE"
+ ebegin "Starting audio entropy gathering daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/audio-entropyd -- ${params}
+ eend ${?}
}
stop() {
-
- ebegin "Stopping famd"
- start-stop-daemon --stop --quiet --exec /usr/bin/audio-entropyd
- eend $?
+ ebegin "Stopping audio entropy gathering daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/audio-entropyd.pid
+ eend ${?}
}
+