summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-24 09:26:55 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-24 09:26:55 +0000
commitbe9d0f595f6d33d579907b45b816cac8c0ba5e79 (patch)
treec147745244e37e47c20ced916e8b245d8b48f635 /media-sound/fluidsynth
parentInitial revision (~x86 masked) closes #21571. (diff)
downloadhistorical-be9d0f595f6d33d579907b45b816cac8c0ba5e79.tar.gz
historical-be9d0f595f6d33d579907b45b816cac8c0ba5e79.tar.bz2
historical-be9d0f595f6d33d579907b45b816cac8c0ba5e79.zip
Initial revision (~x86 masked) closes #21571.
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest4
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.11
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.1.ebuild47
3 files changed, 50 insertions, 2 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index cb72a1c1db8e..afa1d634f16d 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,3 @@
-MD5 4b2043e12ad55057b2ec40133d34b3a0 fluidsynth-1.0.1.ebuild 1282
-MD5 ab7efbc03faa1fa26459bfc11d0e969a ChangeLog 301
+MD5 2a1134df51a1e06385be3f8be032e0e9 fluidsynth-1.0.1.ebuild 1388
+MD5 ce3e185dcf6cf833c99def777a8febc0 ChangeLog 393
MD5 76597f227dd6266c408aab1d4f58da85 files/digest-fluidsynth-1.0.1 68
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.1 b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.1
new file mode 100644
index 000000000000..5ed2a9ae21d0
--- /dev/null
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.1
@@ -0,0 +1 @@
+MD5 7a0ab811d68afcd1d5a40e04a25eaad7 fluidsynth-1.0.1.tar.gz 445834
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.1.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.1.ebuild
new file mode 100644
index 000000000000..887313fd570c
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.1.ebuild,v 1.1 2003/05/24 09:26:43 jje Exp $
+
+DESCRIPTION="IIWU Synth is a software real-time synthesizer based on the
+Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/stable.pkg/1.0.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="alsa ladcca"
+
+DEPEND="ladcca? ( media-libs/ladcca ) \
+ media-libs/ladspa-sdk \
+ alsa? ( media-sound/alsa-driver \
+ media-libs/alsa-lib \
+ media-sound/alsa-utils )"
+
+src_compile() {
+ local myconfig
+ myconfig="--enable-jack-support --enable-ladspa"
+ use ladcca || myconfig="--disable-ladcca ${myconfig}"
+ use alsa || myconfig="--disable-alsa ${myconfig}"
+ # use sse && myconfig="--enable-SSE ${myconfig}"
+ # NOTE: sse use variable is broken now to do a missing header file in
+ # the current release. Waiting for new release to fix.
+ ./configure \
+ ${myconfig} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc AUTHORS COPYING INSTALL NEWS README THANKS TODO
+}
+