summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-18 17:08:44 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-18 17:08:44 +0000
commit318d1b2a778fe239447fb53026ab584c99c2925c (patch)
tree658a0eb189db11c9d282c63f651cc290f5b5be3e /media-sound/pianobooster/pianobooster-0.6.4b.ebuild
parentDon't try to apply non-existing patch wrt #367923 by Adrian Frith. (diff)
downloadhistorical-318d1b2a778fe239447fb53026ab584c99c2925c.tar.gz
historical-318d1b2a778fe239447fb53026ab584c99c2925c.tar.bz2
historical-318d1b2a778fe239447fb53026ab584c99c2925c.zip
Initial import. Ebuild based on work by Nao Nakashima (bug #316449).
Package-Manager: portage-2.2.0_alpha33/cvs/Linux x86_64
Diffstat (limited to 'media-sound/pianobooster/pianobooster-0.6.4b.ebuild')
-rw-r--r--media-sound/pianobooster/pianobooster-0.6.4b.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
new file mode 100644
index 000000000000..dd1976fbbf33
--- /dev/null
+++ b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pianobooster/pianobooster-0.6.4b.ebuild,v 1.1 2011/05/18 17:08:44 radhermit Exp $
+
+EAPI="4"
+
+inherit cmake-utils
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A MIDI file player that teaches how to play the piano"
+HOMEPAGE="http://pianobooster.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fluidsynth"
+
+DEPEND="fluidsynth? ( media-sound/fluidsynth )
+ media-libs/alsa-lib
+ virtual/opengl
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4"
+RDEPEND="${DEPEND}"
+
+DOCS="ReleaseNote.txt ../README.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+S=${WORKDIR}/${MY_P}/src
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_use fluidsynth)
+ )
+
+ cmake-utils_src_configure
+}