summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorben Hohn <torbenh@gentoo.org>2003-06-25 09:40:22 +0000
committerTorben Hohn <torbenh@gentoo.org>2003-06-25 09:40:22 +0000
commit8455a24421db0e206bb486ac9515a26c07783efe (patch)
treea675b95022de3e422491690da9e3f4107ffe4c42 /media-sound/smurf/smurf-0.52.6.ebuild
parentInitial revision (diff)
downloadhistorical-8455a24421db0e206bb486ac9515a26c07783efe.tar.gz
historical-8455a24421db0e206bb486ac9515a26c07783efe.tar.bz2
historical-8455a24421db0e206bb486ac9515a26c07783efe.zip
Initial revision
Diffstat (limited to 'media-sound/smurf/smurf-0.52.6.ebuild')
-rw-r--r--media-sound/smurf/smurf-0.52.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/smurf/smurf-0.52.6.ebuild b/media-sound/smurf/smurf-0.52.6.ebuild
new file mode 100644
index 000000000000..fd25f02a6ff7
--- /dev/null
+++ b/media-sound/smurf/smurf-0.52.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/smurf/smurf-0.52.6.ebuild,v 1.1 2003/06/25 09:40:10 torbenh Exp $
+
+DESCRIPTION="The Smurf Sound Font Editor"
+HOMEPAGE="http://smurf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/smurf/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="nls debug alsa oss png"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/audiofile-0.2.3-r1
+ nls? ( >=sys-devel/gettext-0.11.5-r1 )
+ alsa? ( media-libs/alsa-lib )
+ png? ( >=media-libs/libpng-1.2.5-r4 )"
+
+#RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--with-audiofile"
+ use nls || myconf="${myconf} --disable-nls"
+ use debug || myconf="${myconf} --disable-debug"
+ # --disable-debug seems not to work, but never mind
+ use alsa || myconf="${myconf} --disable-alsa-support"
+ use oss || myconf="${myconf} --disable-oss-support"
+ use png || myconf="${myconf} --disable-splash"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README
+}