summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2004-10-06 14:38:38 +0000
committerChristian Parpart <trapni@gentoo.org>2004-10-06 14:38:38 +0000
commit3b1bd32d8d1c8d286dc4bd83ab74e63da9419812 (patch)
tree9e9b1dc1bc51756f8517d0af92fe1d5c54965ff1 /media-sound/vlevel/vlevel-0.5.ebuild
parentStable on sparc wrt #66501 (diff)
downloadhistorical-3b1bd32d8d1c8d286dc4bd83ab74e63da9419812.tar.gz
historical-3b1bd32d8d1c8d286dc4bd83ab74e63da9419812.tar.bz2
historical-3b1bd32d8d1c8d286dc4bd83ab74e63da9419812.zip
initial import of vlevel ebuild, and, yeah, my very first commit
Diffstat (limited to 'media-sound/vlevel/vlevel-0.5.ebuild')
-rw-r--r--media-sound/vlevel/vlevel-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/vlevel/vlevel-0.5.ebuild b/media-sound/vlevel/vlevel-0.5.ebuild
new file mode 100644
index 000000000000..cd2bb9888e84
--- /dev/null
+++ b/media-sound/vlevel/vlevel-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vlevel/vlevel-0.5.ebuild,v 1.1 2004/10/06 14:38:38 trapni Exp $
+
+DESCRIPTION="VLevel is a dynamic compressor which amplifies the quiet parts of music. It's currently a LADSPA plugin and a command-line filter."
+HOMEPAGE="http://vlevel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vlevel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/ladspa-sdk"
+
+src_compile() {
+ emake CXXFLAGS="$CXXFLAGS -fPIC -DPIC" || die "emake failed"
+}
+
+src_install() {
+ dodir "/usr/bin" || die
+ einstall PREFIX="${D}/usr/bin/" LADSPA_PREFIX="${D}/usr/lib/ladspa/" || die
+ dodoc COPYING INSTALL README TODO docs/notes.txt docs/technical.txt || die
+ dodir "/usr/share/doc/${P}/examples" || die
+ cp utils/* "${D}/usr/share/doc/${P}/examples/" || die
+ chmod 644 "${D}/usr/share/doc/${P}/examples/"* || die
+ gzip -9 "${D}/usr/share/doc/${P}/examples/README" || die
+}
+