summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-25 00:27:11 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-25 00:27:11 +0000
commit026cc84bd30a3b78e2ee887dd21ed2ee9dd78da5 (patch)
tree030acd43dc90c161e8ce0d90ee15169a4c15e5d6 /media-sound
parentfix (diff)
downloadhistorical-026cc84bd30a3b78e2ee887dd21ed2ee9dd78da5.tar.gz
historical-026cc84bd30a3b78e2ee887dd21ed2ee9dd78da5.tar.bz2
historical-026cc84bd30a3b78e2ee887dd21ed2ee9dd78da5.zip
always depend on GNOME, fixes #267
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/files/digest-grip-2.98.3-r11
-rw-r--r--media-sound/grip/grip-2.98.3-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/grip/files/digest-grip-2.98.3-r1 b/media-sound/grip/files/digest-grip-2.98.3-r1
new file mode 100644
index 000000000000..38bd0a93c51d
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-2.98.3-r1
@@ -0,0 +1 @@
+MD5 d7bffaad244fc091f3e4eb3bb39a1e65 grip-2.98.3.tar.gz 782336
diff --git a/media-sound/grip/grip-2.98.3-r1.ebuild b/media-sound/grip/grip-2.98.3-r1.ebuild
new file mode 100644
index 000000000000..bba2d998f076
--- /dev/null
+++ b/media-sound/grip/grip-2.98.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-2.98.3-r1.ebuild,v 1.1 2002/01/25 00:27:11 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based Audio CD Ripper"
+SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
+HOMEPAGE="http://www.nostatic.org/grip"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib
+ virtual/x11
+ gnome-base/gnome-libs
+ gnome-base/ORBit
+ gnome-base/libghttp"
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # apply CFLAGS
+ mv Makefile.in Makefile.in.old
+ sed -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+ Makefile.in.old > Makefile.in
+
+ # fix cdparanoia libs not linking
+ mv src/Makefile.in src/Makefile.in.orig
+ sed -e "s/LDFLAGS =/LDFLAGS = -lcdda_interface -lcdda_paranoia/" \
+ src/Makefile.in.orig > src/Makefile.in
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS CREDITS LICENSE CHANGES README TODO
+}