summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-11-03 17:46:30 +0000
committerAron Griffis <agriffis@gentoo.org>2001-11-03 17:46:30 +0000
commit16a282b8fdef6ebe42ca3601edc2f077aa283de6 (patch)
tree372f6df732b256be9d086b70601ad8d5006b8019 /media-sound
parentnew version (diff)
downloadhistorical-16a282b8fdef6ebe42ca3601edc2f077aa283de6.tar.gz
historical-16a282b8fdef6ebe42ca3601edc2f077aa283de6.tar.bz2
historical-16a282b8fdef6ebe42ca3601edc2f077aa283de6.zip
Minor fixups. use gnome && add-to-gnome-panel
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/aumix/aumix-2.7-r2.ebuild38
-rw-r--r--media-sound/aumix/files/aumix.desktop7
2 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/aumix/aumix-2.7-r2.ebuild b/media-sound/aumix/aumix-2.7-r2.ebuild
new file mode 100644
index 000000000000..8c592cfcfac2
--- /dev/null
+++ b/media-sound/aumix/aumix-2.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Aaron Blew <moath@oddbox.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.7-r2.ebuild,v 1.1 2001/11/03 17:46:30 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Aumix volume/mixer control program."
+SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.gz"
+HOMEPAGE="http://jpj.net/~trevor/aumix/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/gpm-1.19.3
+ alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gtk || myconf="$myconf --without-gtk"
+ use alsa || myconf="$myconf --without-alsa"
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/man \
+ --host=${CHOST} $myconf || die "./configure failed"
+ make || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/aumix.desktop
+ mkdir -p ${D}/usr/share/pixmaps
+ ln -s ../aumix/aumix.xpm ${D}/usr/share/pixmaps
+ fi
+}
diff --git a/media-sound/aumix/files/aumix.desktop b/media-sound/aumix/files/aumix.desktop
new file mode 100644
index 000000000000..0bf998c5ffea
--- /dev/null
+++ b/media-sound/aumix/files/aumix.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Aumix
+Comment=Aumix volume/mixer control program
+Exec=aumix
+Icon=aumix.xpm
+Terminal=0
+Type=Application