summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-03-15 07:53:02 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-03-15 07:53:02 +0000
commit8dde27242243f3e6ee924f69fd62512980cb77cc (patch)
tree7d060cab68ce94a42adfb3f5721045489a8d74e8 /media-sound
parentnew package, provides Abstract Data Types (ADTs) Includes queue, dynamic arra... (diff)
downloadhistorical-8dde27242243f3e6ee924f69fd62512980cb77cc.tar.gz
historical-8dde27242243f3e6ee924f69fd62512980cb77cc.tar.bz2
historical-8dde27242243f3e6ee924f69fd62512980cb77cc.zip
New ebuild (~x86 masked) closes #15787
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rezound/ChangeLog11
-rw-r--r--media-sound/rezound/files/digest-rezound-0.7.0_beta1
-rw-r--r--media-sound/rezound/rezound-0.7.0_beta.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/rezound/ChangeLog b/media-sound/rezound/ChangeLog
new file mode 100644
index 000000000000..7f08858bf31d
--- /dev/null
+++ b/media-sound/rezound/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/rezound
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.1 2003/03/15 07:53:02 jje Exp $
+
+*rezound-0.7.0_beta (15 Mar 2003)
+
+ 15 Mar 2003; jje <jje@gentoo.org> rezound-0.7.0_beta.ebuild:
+ Initial revision. Enabled jack by default. Need to consider USE variables.
+
+ Submitted by: Marc Hildebrand
+
diff --git a/media-sound/rezound/files/digest-rezound-0.7.0_beta b/media-sound/rezound/files/digest-rezound-0.7.0_beta
new file mode 100644
index 000000000000..628d883535ed
--- /dev/null
+++ b/media-sound/rezound/files/digest-rezound-0.7.0_beta
@@ -0,0 +1 @@
+MD5 85add819527aa365bb4cc7fd2c690f8b rezound-0.7.0beta.tar.gz 1006283
diff --git a/media-sound/rezound/rezound-0.7.0_beta.ebuild b/media-sound/rezound/rezound-0.7.0_beta.ebuild
new file mode 100644
index 000000000000..52707c030f42
--- /dev/null
+++ b/media-sound/rezound/rezound-0.7.0_beta.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.7.0_beta.ebuild,v 1.1 2003/03/15 07:53:02 jje Exp $
+
+MY_P="${P/_/}"
+DESCRIPTION="Sound editor and recorder"
+HOMEPAGE="http://rezound.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/rezound/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE="oggvorbis"
+
+DEPEND="virtual/x11
+ virtual/jack
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ >=dev-libs/fftw-2.1.3-r1
+ >x11-libs/fox-1.0.17"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ ./configure --enable-jack --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+ src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYRIGHT ChangeLog FAQ README TODO
+}
+
+