summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-10-30 14:20:41 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-10-30 14:20:41 +0000
commitd661414f7cc8bc628807bc4005b738325eb6a25a (patch)
treefebb9725b3616786bcf27fe1f6be0ab71d3445fe /media-sound
parentVersion bump to 1.4.0_rc8, fixing bugs #77332, #104586, #106811, #108728, cha... (diff)
downloadhistorical-d661414f7cc8bc628807bc4005b738325eb6a25a.tar.gz
historical-d661414f7cc8bc628807bc4005b738325eb6a25a.tar.bz2
historical-d661414f7cc8bc628807bc4005b738325eb6a25a.zip
Initial commit, ebuild by me.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog13
-rw-r--r--media-sound/audacious/Manifest14
-rw-r--r--media-sound/audacious/audacious-0.1.ebuild97
-rw-r--r--media-sound/audacious/files/digest-audacious-0.12
-rw-r--r--media-sound/audacious/metadata.xml9
5 files changed, 135 insertions, 0 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
new file mode 100644
index 000000000000..f90020f09073
--- /dev/null
+++ b/media-sound/audacious/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-sound/audacious
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.1 2005/10/30 14:20:41 chainsaw Exp $
+
+*audacious-0.1 (30 Oct 2005)
+
+ 30 Oct 2005; <chainsaw@gentoo.org> +metadata.xml, +audacious-0.1.ebuild:
+ Initial commit, ebuild by me. Mikmod playback has been disabled, because
+ it fails compilation. AAC playback builds but does not appear to work.
+ If you submit a bug about that, include a patch to enable compilation and
+ include a test track. A bug report that misses either of these will be
+ closed.
+
diff --git a/media-sound/audacious/Manifest b/media-sound/audacious/Manifest
new file mode 100644
index 000000000000..ae29ce7a4bb2
--- /dev/null
+++ b/media-sound/audacious/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 cea98dcd105efdde035b737d3e09b219 ChangeLog 630
+MD5 c20badedf709781712bbdf34542c012d audacious-0.1.ebuild 2387
+MD5 556a78b44b63b6950de07d76f6261e8f files/digest-audacious-0.1 134
+MD5 319fe8f45b51a2d31f8d4e9a4071ca10 metadata.xml 248
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
+
+iD8DBQFDZNbEp5vW4rUFj5oRAmUfAJ9kWOC9IsbdM+fBY+k9Y+oahOUOnwCgniqR
+WSGhpgP6BEZKgFLDnc8YKns=
+=6xL3
+-----END PGP SIGNATURE-----
diff --git a/media-sound/audacious/audacious-0.1.ebuild b/media-sound/audacious/audacious-0.1.ebuild
new file mode 100644
index 000000000000..8f81cb3b0f47
--- /dev/null
+++ b/media-sound/audacious/audacious-0.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-0.1.ebuild,v 1.1 2005/10/30 14:20:41 chainsaw Exp $
+
+IUSE="aac alsa esd flac gnome mmx mp3 nls oss sdl vorbis"
+
+inherit flag-o-matic eutils libtool autotools
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions."
+HOMEPAGE="http://audacious.nenolod.net/Main_Page"
+SRC_URI="http://audacious.nenolod.net/release/audacious-0.1.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# beep-config has a runtime depend on pkg-config
+RDEPEND="app-arch/unzip
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3.1
+ aac? ( >=media-libs/faac-1.24 )
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ gnome? ( >=gnome-base/gconf-2.6.0 )
+ mp3? ( media-libs/id3lib )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+src_unpack() {
+ if ! useq mp3; then
+ ewarn "MP3 support is now optional and you have not enabled it."
+ fi
+
+ unpack ${A}
+ cd ${S}
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --disable-mikmod \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ --includedir=/usr/include/audacious \
+ `use_enable mmx simd` \
+ `use_enable gnome gconf` \
+ `use_enable vorbis` \
+ `use_enable esd` \
+ `use_enable mp3` \
+ `use_enable nls` \
+ `use_enable oss` \
+ `use_enable alsa` \
+ `use_enable flac` \
+ `use_enable mikmod` \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins ${WORKDIR}/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc ${WORKDIR}/README
+
+ # XMMS skin symlinking; bug 70697
+ for SKIN in /usr/share/xmms/Skins/* ; do
+ dosym "$SKIN" /usr/share/audacious/Skins/
+ done
+}
+
+pkg_postinst() {
+ echo
+ einfo "Your XMMS skins, if any, have been symlinked."
+ einfo "MP3 support is now optional, you may want to enable the mp3 USE-flag."
+ echo
+}
diff --git a/media-sound/audacious/files/digest-audacious-0.1 b/media-sound/audacious/files/digest-audacious-0.1
new file mode 100644
index 000000000000..330adcc335bb
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-0.1
@@ -0,0 +1,2 @@
+MD5 540865e944f41a5bb082b13c6b8fd686 audacious-0.1.tgz 2385825
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
diff --git a/media-sound/audacious/metadata.xml b/media-sound/audacious/metadata.xml
new file mode 100644
index 000000000000..a025c77c7636
--- /dev/null
+++ b/media-sound/audacious/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+</pkgmetadata>