summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-23 23:01:00 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-23 23:01:00 +0000
commite3d71f1ddb3ca274f24941c5d84e0d9baf6effad (patch)
tree8dd7d044396729dbe8603ea585059e12ebc46ec0 /media-sound
parentfix for remote buffer overflow (diff)
downloadhistorical-e3d71f1ddb3ca274f24941c5d84e0d9baf6effad.tar.gz
historical-e3d71f1ddb3ca274f24941c5d84e0d9baf6effad.tar.bz2
historical-e3d71f1ddb3ca274f24941c5d84e0d9baf6effad.zip
added rc-script to save and restore mixer settings
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/aumix/aumix-2.7-r3.ebuild50
-rw-r--r--media-sound/aumix/files/aumix.rc645
-rw-r--r--media-sound/aumix/files/digest-aumix-2.7-r31
3 files changed, 96 insertions, 0 deletions
diff --git a/media-sound/aumix/aumix-2.7-r3.ebuild b/media-sound/aumix/aumix-2.7-r3.ebuild
new file mode 100644
index 000000000000..133b915c1126
--- /dev/null
+++ b/media-sound/aumix/aumix-2.7-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.7-r3.ebuild,v 1.1 2001/12/23 23:01:00 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Aumix volume/mixer control program."
+SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.gz"
+HOMEPAGE="http://jpj.net/~trevor/aumix/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/gpm-1.19.3
+ alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gtk || myconf="$myconf --without-gtk"
+ use alsa || myconf="$myconf --without-alsa"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/man \
+ --host=${CHOST} \
+ $myconf || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+
+ make DESTDIR=${D} install
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/aumix.desktop
+ mkdir -p ${D}/usr/share/pixmaps
+ ln -s ../aumix/aumix.xpm ${D}/usr/share/pixmaps
+ fi
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/aumix.rc6 aumix
+}
diff --git a/media-sound/aumix/files/aumix.rc6 b/media-sound/aumix/files/aumix.rc6
new file mode 100644
index 000000000000..142c52dacb33
--- /dev/null
+++ b/media-sound/aumix/files/aumix.rc6
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/files/aumix.rc6,v 1.1 2001/12/23 23:01:00 azarah Exp $
+
+depend() {
+ # User could have some wierd setup that uses /etc/init.d/local ?
+ need modules local
+ use alsa
+}
+
+checkconfig() {
+ if [ -z "`grep 'sound' /proc/devices`" ] && [ ! -d /proc/asound ]
+ then
+ eerror "Sound support has not been compiled into the kernel,"
+ eerror "or is disabled. Please check that the correct modules"
+ eerror "is loaded."
+ return 1
+ fi
+ # /dev/mixer can be a symlink
+ if [ ! -e /dev/mixer ] ; then
+ eerror "/dev/mixer do not exist, please create it, or load the"
+ eerror "correct modules to enable your card's mixer"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ if [ -f /etc/aumixrc ] ; then
+ ebegin "Loading Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -L >/dev/null 2>&1
+ else
+ ebegin "Setting Mixer settings"
+ /usr/bin/aumix -v75 -c75 -w75 >/dev/null 2>&1
+ fi
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Saving Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -S >/dev/null 2>&1
+ eend $?
+}
diff --git a/media-sound/aumix/files/digest-aumix-2.7-r3 b/media-sound/aumix/files/digest-aumix-2.7-r3
new file mode 100644
index 000000000000..592ea7f4a9d4
--- /dev/null
+++ b/media-sound/aumix/files/digest-aumix-2.7-r3
@@ -0,0 +1 @@
+MD5 84ecc331bf6d86d3ac925590fee83af7 aumix-2.7.tar.gz 176128