summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-07 17:53:26 +0000
committerChris White <chriswhite@gentoo.org>2004-08-07 17:53:26 +0000
commite2ce28e1db90be890cb24f5b0093045ee8d274aa (patch)
treeccc94e637b46844201204a85df23118433cfaf4a /media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild
parentAdded some misc #ifdef's to the ssp.c for use with other libcs. Don't disable... (diff)
downloadhistorical-e2ce28e1db90be890cb24f5b0093045ee8d274aa.tar.gz
historical-e2ce28e1db90be890cb24f5b0093045ee8d274aa.tar.bz2
historical-e2ce28e1db90be890cb24f5b0093045ee8d274aa.zip
Bump to 1.1.1 for kernel 2.6 compatibility. Fixes vlc not being able to build on kernel 2.6 systems with dvb in USE flags.
Diffstat (limited to 'media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild')
-rw-r--r--media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild b/media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild
new file mode 100644
index 000000000000..630a1ebefd35
--- /dev/null
+++ b/media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb/linuxtv-dvb-1.1.1.ebuild,v 1.1 2004/08/07 17:53:26 chriswhite Exp $
+
+DESCRIPTION="Standalone DVB driver for Linux kernel 2.4.x"
+HOMEPAGE="http://www.linuxtv.org"
+SRC_URI="http://www.linuxtv.org/download/dvb/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ia64 ~amd64 ~ppc"
+IUSE=""
+DEPEND="virtual/linux-sources"
+#RDEPEND=""
+
+inherit eutils kmod
+
+pkg_setup() {
+ einfo ""
+ einfo "Please make sure that the following option is enabled"
+ einfo "in your current kernel 'Multimedia devices'"
+ einfo "and /usr/src/linux point's to your current kernel"
+ einfo "or make will die."
+ einfo ""
+}
+
+src_compile() {
+ # don't interfere with the kernel arch variables
+ unset ARCH
+
+ #until kmod can be fudged for
+ #this to not have to be included
+ addwrite /usr/src/linux
+
+ emake
+}
+
+src_install() {
+ # see what kernel directory we need to
+ # go to
+ get_kernel_info
+ if is_kernel 2 6
+ then
+ cd ${S}/build-2.6
+ else
+ cd ${S}/build-2.4
+ fi
+
+ #copy over the insmod.sh script
+ #for loading all modules
+ sed -e "s:insmod ./:modprobe :" -i insmod.sh
+ sed -e "s:.${KV_OBJ}::" -i insmod.sh
+ newsbin insmod.sh dvb-module-load
+
+ #install the modules
+ insinto /lib/modules/${KV}/misc
+ doins *.${KV_OBJ}
+
+ #note, REAME-2.6 is an alternative method
+ #of installing dvb besides the ebuild.
+ #since this ebuild is being installed (obviously)
+ #there is no nead for the information contained
+ #within it. If you want to use the README-2.6
+ #method, please get a source tarball, as it will
+ #not be supported - ChrisWhite
+
+ #install the main docs
+ cd ${S}
+ dodoc MAKEDEV-DVB.sh NEWS README README.bt8xx TODO TROUBLESHOOTING
+
+ #install the other docs
+ cd ${S}/doc
+ dodoc HOWTO-use-the-demux-api \
+ README.valgrind HOWTO-use-the-frontend-api \
+ convert.sh valgrind-2.1.0-dvb.patch
+}
+
+pkg_postinst() {
+ depmod -a
+ einfo ""
+ einfo "If you don't use devfs, execute MAKEDEV-DVB.sh to create"
+ einfo "the device nodes. The file is in /usr/share/doc/${PF}/"
+ einfo ""
+ einfo "A file called dvb-module-load has been created to simplify loading all modules."
+ einfo "Call it using 'dvb-module-load {load|debug|unload}'."
+}
+
+pkg_postrm() {
+ depmod -a
+}