summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-10 01:45:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-10 01:45:51 +0000
commitd4e6a7c421db5726ef4b2554b027bd6db65ccbac (patch)
treef131a6f65c677a16161c466f5ad35138e1e72848 /media-video/dirac/files
parentAdd a raid-stop script by Milan Holzäpfel #95594. (diff)
downloadhistorical-d4e6a7c421db5726ef4b2554b027bd6db65ccbac.tar.gz
historical-d4e6a7c421db5726ef4b2554b027bd6db65ccbac.tar.bz2
historical-d4e6a7c421db5726ef4b2554b027bd6db65ccbac.zip
First addition to portage, needed to build dirac codec support on VLC. Added patch to make documentation compilation optional. It uses cppunit if present to do unit testing, but it has its own testsuite also if it's not present.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'media-video/dirac/files')
-rw-r--r--media-video/dirac/files/digest-dirac-0.5.21
-rw-r--r--media-video/dirac/files/dirac-0.5.2-doc.patch59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/dirac/files/digest-dirac-0.5.2 b/media-video/dirac/files/digest-dirac-0.5.2
new file mode 100644
index 000000000000..0db6b5dd6330
--- /dev/null
+++ b/media-video/dirac/files/digest-dirac-0.5.2
@@ -0,0 +1 @@
+MD5 e83e3dc3025c04b3163fbcd1d5e6a328 dirac-0.5.2.tar.gz 671231
diff --git a/media-video/dirac/files/dirac-0.5.2-doc.patch b/media-video/dirac/files/dirac-0.5.2-doc.patch
new file mode 100644
index 000000000000..0f934e0ad69d
--- /dev/null
+++ b/media-video/dirac/files/dirac-0.5.2-doc.patch
@@ -0,0 +1,59 @@
+diff -x '*~' -ur dirac-0.5.2/configure.ac dirac-0.5.2-doc/configure.ac
+--- dirac-0.5.2/configure.ac 2005-05-20 15:05:25.000000000 +0200
++++ dirac-0.5.2-doc/configure.ac 2005-06-10 03:31:58.683588784 +0200
+@@ -105,28 +105,37 @@
+ dnl -----------------------------------------------
+ dnl Checks for optional programs.
+ dnl -----------------------------------------------
+-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
+- if test $HAVE_DOXYGEN = "false"; then
+- AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
+- fi
+-AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
++AC_ARG_ENABLE(doc, AC_HELP_STRING([--enable-doc], [enables doc building (no)]), [enabledoc=${enableval}], [enabledoc=no])
+
+-AC_CHECK_PROG(HAVE_DOT, dot, true, false)
+- if test $HAVE_DOT = "false"; then
+- AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++HAVE_DOXYGEN=false
++HAVE_DOT=false
++HAVE_LATEX=false
++HAVE_DVIPDFM=false
++
++if test "x$enabledoc" != "xno"; then
++ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
++ if test $HAVE_DOXYGEN = "false"; then
++ AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DOT, dot, true, false)
++ if test $HAVE_DOT = "false"; then
++ AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++ fi
++
++ AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
++ if test $HAVE_LATEX = "false"; then
++ AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
++ if test $HAVE_DVIPDFM = "false"; then
++ AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+ fi
++fi
++AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
+ AM_CONDITIONAL(HAVE_DOT, $HAVE_DOT)
+-
+-AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
+- if test $HAVE_LATEX = "false"; then
+- AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_LATEX, $HAVE_LATEX)
+-
+-AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
+- if test $HAVE_DVIPDFM = "false"; then
+- AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_DVIPDFM, $HAVE_DVIPDFM)
+
+ AC_ARG_ENABLE(overlay,