summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-07-08 16:35:34 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-07-08 16:35:34 +0000
commit9ab78f4bd09a894abf860f2c78e16a183b13f141 (patch)
tree0174be86cc7ddef3edcf5105c25e438edf69e31a /media-video
parentdigest update (diff)
downloadhistorical-9ab78f4bd09a894abf860f2c78e16a183b13f141.tar.gz
historical-9ab78f4bd09a894abf860f2c78e16a183b13f141.tar.bz2
historical-9ab78f4bd09a894abf860f2c78e16a183b13f141.zip
added nt which is a gtk based download manager for X. Works great with galeon. Also cleaned up the
realplayer ebuild. Now instead of attempting to fetch the package, it'll check to see if it's there and if not it'll einfo the instructions on where to get it and where to put it. Thanks for the help on that one achim.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/realplayer/realplayer-8.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/media-video/realplayer/realplayer-8.ebuild b/media-video/realplayer/realplayer-8.ebuild
index 997c10dc8840..872df30412b3 100644
--- a/media-video/realplayer/realplayer-8.ebuild
+++ b/media-video/realplayer/realplayer-8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author ben Lutgens <lamer@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/realplayer-8.ebuild,v 1.1 2001/06/21 22:09:53 lamer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/realplayer-8.ebuild,v 1.2 2001/07/08 16:35:34 lamer Exp $
P=rp8_linux20_libc6_i386_cs2_rpm
A=rp8_linux20_libc6_i386_cs2_rpm
@@ -11,18 +11,30 @@ SRC_URI=""
HOMEPAGE="http://"
DEPEND=">=app-arch/rpm-3.0.6"
+
+dyn_fetch() {
+ for y in ${A}
+ do
+ digest_check ${y}
+ if [ $? -ne 0 ]; then
+ einfo "Please download this yourself from www.real.com"
+ einfo "and place it in ${DISTDIR}"
+ exit 1
+ fi
+ done
+}
+
src_unpack() {
# You must download rp8_linux20_libc6_i386_cs2_rpm
# from real.com and put it in ${DISTDIR}
- rpm2cpio ${DISTDIR}/${P} > rp8.cpio
- cpio -i --make-directories < rp8.cpio
+ rpm2cpio ${DISTDIR}/${P} | cpio -i --make-directories
}
src_compile() {
- echo -n "Only binary package, nothing to compile"
+ einfo "Only binary package, nothing to compile"
}