summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-29 19:09:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-29 19:09:14 +0000
commitb51d2fedcee84f1d67135d2976934da5db37f4b7 (patch)
tree969e8f079318af4c7a9816ae67b920df142b6345 /media-video
parentVersion bumped. Closes #21771 (diff)
downloadhistorical-b51d2fedcee84f1d67135d2976934da5db37f4b7.tar.gz
historical-b51d2fedcee84f1d67135d2976934da5db37f4b7.tar.bz2
historical-b51d2fedcee84f1d67135d2976934da5db37f4b7.zip
Version bumped. Closes #21771
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/Manifest4
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.61
-rw-r--r--media-video/transcode/transcode-0.6.6.ebuild127
3 files changed, 130 insertions, 2 deletions
diff --git a/media-video/transcode/Manifest b/media-video/transcode/Manifest
index e82ad230c471..cfb4c30e51c8 100644
--- a/media-video/transcode/Manifest
+++ b/media-video/transcode/Manifest
@@ -1,9 +1,9 @@
-MD5 f25f91208f9f6ba5453a65e1072e4fea ChangeLog 8427
+MD5 edc5bacaba8695928c5f8e008c253483 ChangeLog 8567
MD5 df648b9270825d3e3a34a1837dc21306 transcode-0.6.2.ebuild 3120
MD5 94bd38e13fa090bcc32202151996f459 transcode-0.6.3.ebuild 3061
MD5 78bfec2109a5353a59c5cf9c01a177e4 transcode-0.6.4.ebuild 3294
MD5 998b3c4e71c8c0ae68fbd4118e333431 transcode-0.6.4_pre20030409.ebuild 3306
-MD5 c78da33401360c455a6750186bb295f6 transcode-0.6.6.ebuild 3393
+MD5 6a0b96d4f85ada728dcb0332496ecc44 transcode-0.6.6.ebuild 3293
MD5 03629a858586307611c7d7c2a2dc1505 files/digest-transcode-0.6.2 68
MD5 225a843999c440c3060e96b9fe6fca35 files/digest-transcode-0.6.3 68
MD5 1015c51dd24d8191b78b2465b24c1b83 files/digest-transcode-0.6.4 68
diff --git a/media-video/transcode/files/digest-transcode-0.6.6 b/media-video/transcode/files/digest-transcode-0.6.6
new file mode 100644
index 000000000000..65b3b6fd339a
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.6
@@ -0,0 +1 @@
+MD5 31348a10fc7de8e629e94f67849b3124 transcode-0.6.6.tar.gz 2643681
diff --git a/media-video/transcode/transcode-0.6.6.ebuild b/media-video/transcode/transcode-0.6.6.ebuild
new file mode 100644
index 000000000000..0dfc52c362f9
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.6.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.6.ebuild,v 1.1 2003/06/29 19:08:54 mholzer Exp $
+
+inherit libtool flag-o-matic
+
+# Don't build with -mfpmath=sse || -fPic or it will break. (Bug #14920)
+filter-flags -mfpmath=sse
+filter-flags -fPIC
+
+filter-flags "-maltivec -mabi=altivec"
+
+MY_P="${P/_pre/.}"
+S=${WORKDIR}/${MY_P}
+IUSE="sdl mmx mpeg sse encode X quicktime avi altivec"
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.zebra.fh-weingarten.de/~transcode/pre/${MY_P}.tar.gz"
+HOMEPAGE="http://zebra.fh-weingarten.de/~transcode/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.99
+ x86? ( >=dev-lang/nasm-0.98.34 )
+ >=media-libs/libdvdread-0.9.0
+ >=media-video/ffmpeg-0.4.6
+ >=media-libs/xvid-0.9.1
+ >=media-video/mjpegtools-1.6.0
+ >=dev-libs/lzo-1.08
+ >=media-libs/libfame-0.9.0
+ >=media-gfx/imagemagick-5.4.9.0
+ media-libs/netpbm
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.25 )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux media-libs/openquicktime )"
+
+src_unpack() {
+ unpack ${A}
+
+ if has_version '>=media-libs/netpbm-9.13'
+ then
+ einfo "New netbpm (>9.12)..."
+ cp ${S}/contrib/subrip/Makefile ${S}/contrib/subrip/Makefile.orig
+ sed -e 's:-lppm:-lnetpbm:' \
+ ${S}/contrib/subrip/Makefile.orig > ${S}/contrib/subrip/Makefile
+ else
+ einfo "Old netbpm (<=9.12)..."
+ fi
+}
+
+src_compile() {
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=
+ myconf="--with-dvdread"
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+ use altivec \
+ && myconf="${myconf} --enable-altivec" \
+ || myconf="${myconf} --disable-altivec"
+
+ use avi \
+ && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+ || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ && myconf="${myconf} --with-qt --with-openqt" \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postproc/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+
+ econf ${myconf} CFLAGS="${CFLAGS} -DDCT_YUV_PRECISION=1" || die
+
+ # Do not use emake !!
+ # export CFLAGS="${CFLAGS} -DDCT_YUV_PRECISION=1"
+
+ make all || die
+
+ # subrip stuff
+ cd contrib/subrip
+ make || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+
+ # subrip stuff
+ cd contrib/subrip
+ dobin pgm2txt srttool subtitle2pgm subtitle2vobsub
+ einfo ""
+ einfo "This ebuild uses subtitles !!!"
+ einfo ""
+}