summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-22 10:52:18 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-22 10:52:18 +0000
commitccbfc4a0a7f462be4822ea97f5e46f4efbaf524b (patch)
tree0feb264d47e2c1597163541c3081c6cdf59abcd6 /net-analyzer/amap/files
parentMarked ~mips (diff)
downloadhistorical-ccbfc4a0a7f462be4822ea97f5e46f4efbaf524b.tar.gz
historical-ccbfc4a0a7f462be4822ea97f5e46f4efbaf524b.tar.bz2
historical-ccbfc4a0a7f462be4822ea97f5e46f4efbaf524b.zip
Version bump for bug 82876; updated pcre patch and added a patch to fix amap's icky lvalue casts which cause numerous warnings w/gcc-3.4. Updated HOMEPAGE and SRC_URI. Marked 4.7 stable on x86.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'net-analyzer/amap/files')
-rw-r--r--net-analyzer/amap/files/4.8-system-pcre.patch45
-rw-r--r--net-analyzer/amap/files/amap-4.8-fix-icky-lvalue-casts.diff124
-rw-r--r--net-analyzer/amap/files/digest-amap-4.81
3 files changed, 170 insertions, 0 deletions
diff --git a/net-analyzer/amap/files/4.8-system-pcre.patch b/net-analyzer/amap/files/4.8-system-pcre.patch
new file mode 100644
index 000000000000..097bfbf45eb5
--- /dev/null
+++ b/net-analyzer/amap/files/4.8-system-pcre.patch
@@ -0,0 +1,45 @@
+diff --exclude='*~' -urN amap-4.8.orig/amap-inc.h amap-4.8/amap-inc.h
+--- amap-4.8.orig/amap-inc.h 2005-02-21 21:47:47.251638320 -0500
++++ amap-4.8/amap-inc.h 2005-02-21 21:48:27.774477912 -0500
+@@ -20,7 +20,7 @@
+ #include <errno.h>
+ #include <sys/resource.h>
+ #include <sys/wait.h>
+-#include "pcre-3.9/pcre.h"
++#include <pcre.h>
+ #ifdef OPENSSL
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
+diff --exclude='*~' -urN amap-4.8.orig/configure amap-4.8/configure
+--- amap-4.8.orig/configure 2005-02-21 21:47:47.240639992 -0500
++++ amap-4.8/configure 2005-02-21 21:48:41.379409648 -0500
+@@ -13,10 +13,6 @@
+ exit 0
+ fi
+
+-cd pcre-3.9 || exit 1
+-./configure || exit 1
+-cd ..
+-
+ echo
+ echo
+ echo "Starting amap auto configuration ..."
+diff --exclude='*~' -urN amap-4.8.orig/Makefile.am amap-4.8/Makefile.am
+--- amap-4.8.orig/Makefile.am 2005-02-21 21:47:47.242639688 -0500
++++ amap-4.8/Makefile.am 2005-02-21 21:49:16.070135856 -0500
+@@ -1,5 +1,5 @@
+ CC=gcc
+-LIB=-lpcre -L./pcre-3.9/ -I./pcre-3.9/
++LIB=-lpcre
+ OPT=-O2
+ OPT_DEBUG=-ggdb -Wall -lefence
+ BINDIR=/bin
+@@ -7,7 +7,7 @@
+ MANDIR=/man/man1
+ SCRIPTS=appdefs.trig appdefs.resp appdefs.rpc
+ MANPAGE=amap.1
+-all: pcre strip
++all: amap amapcrap
+
+ pcre:
+ cd pcre-3.9 && make
diff --git a/net-analyzer/amap/files/amap-4.8-fix-icky-lvalue-casts.diff b/net-analyzer/amap/files/amap-4.8-fix-icky-lvalue-casts.diff
new file mode 100644
index 000000000000..a22afecda61e
--- /dev/null
+++ b/net-analyzer/amap/files/amap-4.8-fix-icky-lvalue-casts.diff
@@ -0,0 +1,124 @@
+diff --exclude='*~' -urN amap-4.8.orig/amap.c amap-4.8/amap.c
+--- amap-4.8.orig/amap.c 2005-02-21 21:55:38.616979896 -0500
++++ amap-4.8/amap.c 2005-02-21 22:27:37.473269400 -0500
+@@ -352,8 +352,8 @@
+
+
+ // AMAP_MEMDUP //
+-char *amap_memdup(char *string, int len) {
+- char *ptr;
++void *amap_memdup(char *string, int len) {
++ void *ptr;
+
+ if (string == NULL)
+ return NULL;
+@@ -441,7 +441,7 @@
+ if ((line[0] != '#') && (index(line, ':') != NULL) && (only_trigger == NULL || strncmp(only_trigger, line, strlen(only_trigger)) == 0)) { // weed out comment lines
+ count_triggers++;
+ if (count_triggers > 1) {
+- if (((amap_struct_triggers*) trigger->next = (amap_struct_triggers*) malloc(sizeof(amap_struct_triggers))) == NULL)
++ if ((trigger->next = malloc(sizeof(amap_struct_triggers))) == NULL)
+ amap_error("malloc failed");
+ trigger = (amap_struct_triggers*) trigger->next;
+ memset(trigger, 0, sizeof(amap_struct_triggers));
+@@ -609,7 +609,7 @@
+ if ((line[0] != '#') && (index(line, ':') != NULL)) { // weed out comment lines
+ count_responses++;
+ if (count_responses > 1) {
+- if (((amap_struct_responses*) response->next = (amap_struct_responses*) malloc(sizeof(amap_struct_responses))) == NULL)
++ if ((response->next = malloc(sizeof(amap_struct_responses))) == NULL)
+ amap_error("malloc failed");
+ response = (amap_struct_responses*) response->next;
+ memset(response, 0, sizeof(amap_struct_responses));
+@@ -656,7 +656,7 @@
+ triggerptr_tmp->trigger = strdup(triggerptr);
+ if (i + 1 < count) {
+ triggerptr = ptr;
+- if (((amap_struct_triggerptr*) triggerptr_tmp->next = malloc(sizeof(amap_struct_triggerptr))) == NULL)
++ if ((triggerptr_tmp->next = malloc(sizeof(amap_struct_triggerptr))) == NULL)
+ amap_error("malloc failed");
+ triggerptr_tmp = (amap_struct_triggerptr*) triggerptr_tmp->next;
+ triggerptr_tmp->next = NULL;
+@@ -728,7 +728,7 @@
+ if (opt->verbose > 1)
+ printf("%d/%s ", port_tmp->port, port_tmp->ip_prot == AMAP_PROTO_TCP ? "tcp" : "udp");
+ if (pto != pfrom) {
+- if (((amap_struct_ports *) port_tmp->next = (amap_struct_ports *) malloc(sizeof(amap_struct_ports))) == NULL)
++ if ((port_tmp->next = malloc(sizeof(amap_struct_ports))) == NULL)
+ amap_error("malloc failed");
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ memset(port_tmp, 0, sizeof(amap_struct_ports));
+@@ -768,7 +768,7 @@
+ amap_error("line in nmap file is too long or not terminating with \\n: %s", line);
+ if ((line[0] == 'H') && (index(line, ' ') != NULL) && ((portinfo = strstr(line, "/open/")) != NULL)) { // just care for data lines
+ if (count != 0) {
+- if (((amap_struct_targets*) target->next = (amap_struct_targets*) malloc(sizeof(amap_struct_targets))) == NULL)
++ if ((target->next = malloc(sizeof(amap_struct_targets))) == NULL)
+ amap_error("malloc failed");
+ target = (amap_struct_targets*) target->next;
+ memset(target, 0, sizeof(amap_struct_targets));
+@@ -809,7 +809,7 @@
+ if (opt->verbose > 1)
+ printf("%d/%s ", port_tmp->port, port_tmp->ip_prot == AMAP_PROTO_TCP ? "tcp" : "udp");
+ while ((portinfo = strstr(proto + 1, "/open/")) != NULL) {
+- if (((amap_struct_ports *) port_tmp->next = (amap_struct_ports *) malloc(sizeof(amap_struct_ports))) == NULL)
++ if ((port_tmp->next = malloc(sizeof(amap_struct_ports))) == NULL)
+ amap_error("malloc failed");
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ memset(port_tmp, 0, sizeof(amap_struct_ports));
+@@ -1024,7 +1024,7 @@
+ } else {
+ while (ids->next != NULL)
+ ids = (amap_struct_identifications*) ids->next;
+- if (((char *) ids->next = malloc(sizeof(amap_struct_identifications))) == NULL)
++ if ((ids->next = malloc(sizeof(amap_struct_identifications))) == NULL)
+ amap_error("malloc failed");
+ ids = (amap_struct_identifications*) ids->next;
+ }
+@@ -1765,7 +1765,7 @@
+ fcntl(s, F_SETFL, O_NONBLOCK);
+ coms[i].timer = time(NULL);
+ coms[i].socket = s;
+- (char*) coms[i].sockaddr = amap_memdup((char *) &target_in, sizeof(target_in));
++ coms[i].sockaddr = amap_memdup((char *) &target_in, sizeof(target_in));
+ coms[i].sockaddr_len = sizeof(target_in);
+ scaninfo.running++;
+ errno = 0;
+@@ -2098,7 +2098,7 @@
+ port_tmp = amap_add_port_string(port_tmp, argv[optind + 1], cmd_proto, &opt);
+ i = optind + 2;
+ while (i < argc) {
+- if (((amap_struct_ports *) port_tmp->next = (amap_struct_ports *) malloc(sizeof(amap_struct_ports))) == NULL)
++ if ((port_tmp->next = malloc(sizeof(amap_struct_ports))) == NULL)
+ amap_error("malloc failed");
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ memset(port_tmp, 0, sizeof(amap_struct_ports));
+@@ -2110,7 +2110,7 @@
+ while (strcmp(target_tmp->target, argv[optind]) != 0 && target_tmp->next != NULL)
+ target_tmp = (amap_struct_targets *) target_tmp->next;
+ if (strcmp(target_tmp->target, argv[optind]) != 0) { // it is not
+- if (((amap_struct_targets *) target_tmp->next = (amap_struct_targets *) malloc(sizeof(amap_struct_targets))) == NULL)
++ if ((target_tmp->next = malloc(sizeof(amap_struct_targets))) == NULL)
+ amap_error("malloc failed");
+ target_tmp = (amap_struct_targets *) target_tmp->next;
+ memset(target_tmp, 0, sizeof(amap_struct_targets));
+@@ -2125,7 +2125,7 @@
+ printf("%d/%s ", port_tmp->port, port_tmp->ip_prot == AMAP_PROTO_TCP ? "tcp" : "udp");
+ i = optind + 2;
+ while (i < argc) {
+- if (((amap_struct_ports *) port_tmp->next = (amap_struct_ports *) malloc(sizeof(amap_struct_ports))) == NULL)
++ if ((port_tmp->next = malloc(sizeof(amap_struct_ports))) == NULL)
+ amap_error("malloc failed");
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ memset(port_tmp, 0, sizeof(amap_struct_ports));
+@@ -2155,7 +2155,7 @@
+ while (((port_tmp->ip_prot != cmd_proto) || (port_tmp->port != (unsigned short int) pfrom)) && port_tmp->next != NULL)
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ if (port_tmp->port != (unsigned short int) pfrom) { // we have to add the port
+- if (((amap_struct_ports *) port_tmp->next = (amap_struct_ports *) malloc(sizeof(amap_struct_ports))) == NULL)
++ if ((port_tmp->next = malloc(sizeof(amap_struct_ports))) == NULL)
+ amap_error("malloc failed");
+ port_tmp = (amap_struct_ports *) port_tmp->next;
+ memset(port_tmp, 0, sizeof(amap_struct_ports));
+Files amap-4.8.orig/.amap.c.swp and amap-4.8/.amap.c.swp differ
+Files amap-4.8.orig/.amap.h.swp and amap-4.8/.amap.h.swp differ
diff --git a/net-analyzer/amap/files/digest-amap-4.8 b/net-analyzer/amap/files/digest-amap-4.8
new file mode 100644
index 000000000000..81a50fc78fa3
--- /dev/null
+++ b/net-analyzer/amap/files/digest-amap-4.8
@@ -0,0 +1 @@
+MD5 db6f6aa06afc6aeea7c7e0c594c73b69 amap-4.8.tar.gz 258019