summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
commit0ede8ad041fb595b1fa3e901b3184bb990c9c211 (patch)
treebf523b3d2e6319a93bce595e1e78579b485b1e7e /net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
parentVersion bump for #221197 (diff)
downloadhistorical-0ede8ad041fb595b1fa3e901b3184bb990c9c211.tar.gz
historical-0ede8ad041fb595b1fa3e901b3184bb990c9c211.tar.bz2
historical-0ede8ad041fb595b1fa3e901b3184bb990c9c211.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. Package-Manager: portage-2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.8.2.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
index 30c2a0ac9048..3b50282e505d 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild,v 1.2 2008/03/18 19:09:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild,v 1.3 2008/06/15 09:21:26 zmedico Exp $
inherit distutils
@@ -35,8 +35,13 @@ src_install() {
newins "${FILESDIR}"/${PN}-logrotate ${PN} || die
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
pkg_postinst() {
- if has_version '<net-analyzer/fail2ban-0.7' ; then
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"