summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-01-21 18:21:58 +0000
committerMichael Boman <mboman@gentoo.org>2004-01-21 18:21:58 +0000
commit56b08062be649d432538bbd4f0e7a698bd739b34 (patch)
tree9e468e01c3bbf3184f8f005d3bd1ac601332c318 /net-analyzer/honeyd
parentNew upstream version. Fixes bug #38934 (Security bug). (diff)
downloadhistorical-56b08062be649d432538bbd4f0e7a698bd739b34.tar.gz
historical-56b08062be649d432538bbd4f0e7a698bd739b34.tar.bz2
historical-56b08062be649d432538bbd4f0e7a698bd739b34.zip
New upstream version. Fixes bug #38934 (Security bug).
Diffstat (limited to 'net-analyzer/honeyd')
-rw-r--r--net-analyzer/honeyd/Manifest4
-rw-r--r--net-analyzer/honeyd/files/digest-honeyd-0.82
-rw-r--r--net-analyzer/honeyd/honeyd-0.8.ebuild75
3 files changed, 79 insertions, 2 deletions
diff --git a/net-analyzer/honeyd/Manifest b/net-analyzer/honeyd/Manifest
index 937bf2192a8f..c73b998dab55 100644
--- a/net-analyzer/honeyd/Manifest
+++ b/net-analyzer/honeyd/Manifest
@@ -1,9 +1,9 @@
-MD5 81ca02579abc3614b81f95f2cec95f2f ChangeLog 1135
+MD5 43f36dcd7ce0821a5efb3144102d7ee7 ChangeLog 1326
MD5 0fd3b15a3e0705571ed5a9cfa86f8676 honeyd-0.4a.ebuild 929
MD5 a79fb75b18765c3f3f6f1f0852cba0af honeyd-0.5.ebuild 1304
MD5 29bb0b9edff3ed2e2e191c6902baf262 honeyd-0.6a.ebuild 1045
MD5 bd7361d8f6ad2e4ff78366f0a7f0d6cc honeyd-0.7a.ebuild 1902
-MD5 c712ff5e4127cc4cff5ef7f466d7a1bf honeyd-0.8.ebuild 1911
+MD5 abce94000c37e1ecf70026632f3226b2 honeyd-0.8.ebuild 1931
MD5 11bc0f49cb24494a0185158ccda1df5d files/digest-honeyd-0.4a 63
MD5 b323e42a8d857ed4c1f1c4a0f7bf256f files/digest-honeyd-0.5 177
MD5 6ed6ff3b7fff0952e52a113d818a62ae files/digest-honeyd-0.6a 63
diff --git a/net-analyzer/honeyd/files/digest-honeyd-0.8 b/net-analyzer/honeyd/files/digest-honeyd-0.8
new file mode 100644
index 000000000000..11e1c466a55e
--- /dev/null
+++ b/net-analyzer/honeyd/files/digest-honeyd-0.8
@@ -0,0 +1,2 @@
+MD5 d8d3692176d2f78841f7a3384ccb0b73 honeyd-0.8.tar.gz 440264
+MD5 98f56c64ca76f52de42c5a0342cdd009 honeyd-0.7a-beta2.tgz 2027537
diff --git a/net-analyzer/honeyd/honeyd-0.8.ebuild b/net-analyzer/honeyd/honeyd-0.8.ebuild
new file mode 100644
index 000000000000..f0cb5755d6fe
--- /dev/null
+++ b/net-analyzer/honeyd/honeyd-0.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-0.8.ebuild,v 1.1 2004/01/21 18:21:43 mboman Exp $
+
+inherit eutils
+
+DESCRIPTION="Honeyd is a small daemon that creates virtual hosts on a network"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz
+ http://www.tracking-hackers.com/solutions/honeyd/honeyd-0.7a-beta2.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc"
+DEPEND=">=dev-libs/libdnet-1.7
+ >=dev-libs/libevent-0.6
+ >=net-libs/libpcap-0.7.1"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ sed -i "s:^CFLAGS = -O2:CFLAGS = ${CFLAGS}:g" Makefile.in
+}
+
+src_compile() {
+ econf --with-libdnet=/usr || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ dodoc README
+ dosbin honeyd
+
+ einstall
+
+ rm ${D}/usr/bin/honeyd
+ rm ${D}/usr/share/honeyd/README
+
+ dodir /usr/share/honeyd/scripts
+ exeinto /usr/share/honeyd/scripts
+ doexe scripts/web.sh scripts/router-telnet.pl scripts/test.sh
+
+ # This adds all the services and example configurations collected
+ # by Lance Spitzer
+
+ # Install the white-papers if 'doc' USE flags are specified
+ use doc && (
+ cd ${WORKDIR}/honeyd-0.7a-beta2/contrib
+ dodoc *
+ )
+
+ # Install the example configurations
+ cd ${WORKDIR}/honeyd-0.7a-beta2
+ dodoc honeyd.conf nmap.prints nmap.assoc pf.os xprobe2.conf
+ dodoc honeyd.conf.simple honeyd.conf.bloat nmap.prints.new
+ dodoc xprobe2.conf.new honeyd.conf.networks
+
+ # Install example start/stop scripts.. Those should _really_
+ # be re-written to gentoo instead..
+ dodoc start-arpd.sh start-honeyd.sh
+
+ # Install all the example scripts
+ cd ${WORKDIR}/honeyd-0.7a-beta2/scripts
+ cp -R * ${D}/usr/share/honeyd/scripts/
+ cd ${D}/usr/share/honeyd/scripts/
+ find -type f -name "*.sh" -o -name "*.pl" | xargs chmod +x
+
+
+}
+