summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-08-25 09:42:44 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-08-25 09:42:44 +0000
commit81676a865f83530fd2561bae415b11744b025c6c (patch)
tree6b9a84bad7f64443e5bdd637d95c912ae711b9f6 /net-analyzer/honeyd
parentversion bump (diff)
downloadhistorical-81676a865f83530fd2561bae415b11744b025c6c.tar.gz
historical-81676a865f83530fd2561bae415b11744b025c6c.tar.bz2
historical-81676a865f83530fd2561bae415b11744b025c6c.zip
version bump
Diffstat (limited to 'net-analyzer/honeyd')
-rw-r--r--net-analyzer/honeyd/Manifest4
-rw-r--r--net-analyzer/honeyd/files/digest-honeyd-0.6a1
-rw-r--r--net-analyzer/honeyd/honeyd-0.6a.ebuild44
3 files changed, 47 insertions, 2 deletions
diff --git a/net-analyzer/honeyd/Manifest b/net-analyzer/honeyd/Manifest
index 231e4f632310..42479322fe8c 100644
--- a/net-analyzer/honeyd/Manifest
+++ b/net-analyzer/honeyd/Manifest
@@ -1,7 +1,7 @@
MD5 0fd3b15a3e0705571ed5a9cfa86f8676 honeyd-0.4a.ebuild 929
-MD5 5bd3174575f5a6cfd2d56b5078718b31 ChangeLog 670
+MD5 30adb64e910532100bfd55d6971006dd ChangeLog 822
MD5 a79fb75b18765c3f3f6f1f0852cba0af honeyd-0.5.ebuild 1304
-MD5 85cbc5d87669e765c0dee9031efd60e8 honeyd-0.6a.ebuild 1066
+MD5 ab55a7ce2345028bedd3d11cb9b74d68 honeyd-0.6a.ebuild 1067
MD5 11bc0f49cb24494a0185158ccda1df5d files/digest-honeyd-0.4a 63
MD5 b323e42a8d857ed4c1f1c4a0f7bf256f files/digest-honeyd-0.5 177
MD5 6ed6ff3b7fff0952e52a113d818a62ae files/digest-honeyd-0.6a 63
diff --git a/net-analyzer/honeyd/files/digest-honeyd-0.6a b/net-analyzer/honeyd/files/digest-honeyd-0.6a
new file mode 100644
index 000000000000..015b7437743f
--- /dev/null
+++ b/net-analyzer/honeyd/files/digest-honeyd-0.6a
@@ -0,0 +1 @@
+MD5 d8743bde540db637a7cd7a19214a8265 honeyd-0.6a.tar.gz 366878
diff --git a/net-analyzer/honeyd/honeyd-0.6a.ebuild b/net-analyzer/honeyd/honeyd-0.6a.ebuild
new file mode 100644
index 000000000000..79d708ec95cc
--- /dev/null
+++ b/net-analyzer/honeyd/honeyd-0.6a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-0.6a.ebuild,v 1.1 2003/08/25 09:42:37 aliz Exp $
+
+inherit eutils
+
+DESCRIPTION="Honeyd is a small daemon that creates virtual hosts on a network"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND=">=net-libs/libdnet-1.4
+ >=net-libslibevent-0.6
+ >=net-libs/libpcap-0.7.1"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ econf --with-libdnet=/usr || die "econf failed"
+ emake CFLAGS="${CFLAGS} -Wall -g \
+ -DPATH_HONEYDDATA=${honeyddatadir} \
+ -DPATH_HONEYDLIB=${honeydlibdir} " \
+ || die "emake failed"
+}
+
+src_install() {
+ dodoc README
+ dosbin honeyd
+
+ einstall
+
+ rm ${D}/usr/bin/honeyd
+ rm ${D}/usr/share/honeyd/README
+
+ dodir /usr/share/honeyd/scripts
+ exeinto /usr/share/honeyd/scripts
+ doexe scripts/web.sh scripts/router-telnet.pl scripts/test.sh
+}
+