summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-09 00:11:49 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-09 00:11:49 +0000
commita20be1c784ae17e7490b8b2085c1894a28f51dd9 (patch)
tree43cacf3536f440770f2012627b2ad96b1e2b501e /net-analyzer/netwox
parentVersion bump. (diff)
downloadhistorical-a20be1c784ae17e7490b8b2085c1894a28f51dd9.tar.gz
historical-a20be1c784ae17e7490b8b2085c1894a28f51dd9.tar.bz2
historical-a20be1c784ae17e7490b8b2085c1894a28f51dd9.zip
Version bump.
Package-Manager: portage-2.2.0_alpha116/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/netwox')
-rw-r--r--net-analyzer/netwox/ChangeLog9
-rw-r--r--net-analyzer/netwox/netwox-5.39.0.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/net-analyzer/netwox/ChangeLog b/net-analyzer/netwox/ChangeLog
index 7df2439eacd4..8c0200105008 100644
--- a/net-analyzer/netwox/ChangeLog
+++ b/net-analyzer/netwox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/netwox
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/ChangeLog,v 1.35 2011/03/02 15:49:44 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/ChangeLog,v 1.36 2012/07/09 00:11:49 jer Exp $
+
+*netwox-5.39.0 (09 Jul 2012)
+
+ 09 Jul 2012; Jeroen Roovers <jer@gentoo.org> +netwox-5.39.0.ebuild:
+ Version bump.
02 Mar 2011; Jeroen Roovers <jer@gentoo.org> netwox-5.38.0.ebuild:
Readd old homepage.
diff --git a/net-analyzer/netwox/netwox-5.39.0.ebuild b/net-analyzer/netwox/netwox-5.39.0.ebuild
new file mode 100644
index 000000000000..af7e2dcd7369
--- /dev/null
+++ b/net-analyzer/netwox/netwox-5.39.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/netwox-5.39.0.ebuild,v 1.1 2012/07/09 00:11:49 jer Exp $
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Toolbox of 217 utilities for testing Ethernet/IP networks"
+HOMEPAGE="
+ http://ntwox.sourceforge.net/
+ http://www.laurentconstantin.com/en/netw/netwox/
+"
+SRC_URI="mirror://sourceforge/ntwox/${P}-src.tgz
+ doc? ( mirror://sourceforge/ntwox/${P}-doc_html.tgz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=net-libs/libnet-1.1.1"
+
+DEPEND="net-libs/libpcap
+ ~net-libs/netwib-${PV}
+ ${RDEPEND}"
+
+S="${WORKDIR}/${P}-src/src"
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr/local:/usr:" \
+ -e "s:=ar:=$(tc-getAR):" \
+ -e "s:=ranlib:=$(tc-getRANLIB):" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ config.dat || die "patching config.dat failed"
+ sed -i \
+ -e "s:-o netwox:& \${LDFLAGS}:g" \
+ -e 's: ; make: ; \\$(MAKE):g' \
+ genemake || die "patching genemake failed"
+}
+
+src_configure() {
+ sh genemake || die "problem creating Makefile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc ../README.TXT
+ if use doc;
+ then
+ mv "${WORKDIR}"/${P}-doc_html "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dodoc "${S}"/../doc/{changelog.txt,credits.txt} \
+ "${S}"/../doc/{problemreport.txt,problemusageunix.txt,todo.txt}
+}