summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-14 10:05:52 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-14 10:05:52 +0000
commit8ec78272bad7af32cfa64f22568846a2af47f89e (patch)
treee161b17d915d610ab15e0938d98d3c213c5aa88c /net-analyzer/ntop/files
parentRemove old. Silence repoman. (diff)
downloadhistorical-8ec78272bad7af32cfa64f22568846a2af47f89e.tar.gz
historical-8ec78272bad7af32cfa64f22568846a2af47f89e.tar.bz2
historical-8ec78272bad7af32cfa64f22568846a2af47f89e.zip
Version bump (#271453).
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/ntop/files')
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch122
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch58
2 files changed, 180 insertions, 0 deletions
diff --git a/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch b/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch
new file mode 100644
index 000000000000..c8ad557a10b6
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch
@@ -0,0 +1,122 @@
+diff -Nru ntop-3.3.10.orig/configure.in ntop-3.3.10/configure.in
+--- ntop-3.3.10.orig/configure.in 2009-06-14 09:49:59.000000000 +0000
++++ ntop-3.3.10/configure.in 2009-06-14 10:01:27.000000000 +0000
+@@ -1959,39 +1959,7 @@
+ fi
+
+ dnl> GeoIP (http://www.maxmind.com/)
+-if test -f "GeoIP.tar.gz"; then
+- echo "GeoIP already present on this machine"
+-else
+- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
+-fi
+-tar xvfz GeoIP.tar.gz
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-cd $GEO_DIR; ./configure --prefix=${prefix}; make; cd ..
+-# OSX Fix
+-GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+-if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
+-fi
+-
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+-if test -f "GeoIPASNum.dat"; then
+- echo "GeoIPASNum.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
+- gunzip GeoIPASNum.dat.gz
+-fi
+-
+-
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-GEO_IP="$GEO_DIR/libGeoIP/"
+-CFLAGS="$CFLAGS -I$GEO_IP"
+-LDFLAGS="-L$GEO_IP.libs/ -lGeoIP $LDFLAGS"
++LDFLAGS="$LDFLAGS -lGeoIP"
+
+ dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
+
+@@ -2157,7 +2125,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+ AC_SUBST(GETOPT_H)
+ AC_SUBST(GETOPT_C)
+
+diff -Nru ntop-3.3.10.orig/globals-core.c ntop-3.3.10/globals-core.c
+--- ntop-3.3.10.orig/globals-core.c 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/globals-core.c 2009-06-14 11:50:53.000000000 +0000
+@@ -503,19 +503,18 @@
+ struct stat statbuf;
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+ }
+@@ -525,19 +524,18 @@
+
+ /* *************************** */
+
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+ }
+diff -Nru ntop-3.3.10.orig/Makefile.am ntop-3.3.10/Makefile.am
+--- ntop-3.3.10.orig/Makefile.am 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/Makefile.am 2009-06-14 09:50:14.000000000 +0000
+@@ -76,9 +76,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -270,8 +268,6 @@
+
+ install: install-recursive
+
+- cd @GEO_DIR@; make install
+-
+ @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
+
+ @echo ""
diff --git a/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch
new file mode 100644
index 000000000000..a4fe7ab3f732
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch
@@ -0,0 +1,58 @@
+diff -Nru ntop-3.3.10.orig/Makefile.am ntop-3.3.10/Makefile.am
+--- ntop-3.3.10.orig/Makefile.am 2009-06-14 10:05:37.000000000 +0000
++++ ntop-3.3.10/Makefile.am 2009-06-14 10:13:28.000000000 +0000
+@@ -45,7 +45,6 @@
+
+ #AM_CFLAGS =
+ #AM_LDFLAGS=
+-ACLOCAL_AMFLAGS=-l m4
+
+ DISTCLEANFILES = trivialcompilemessage *.db #* *~ *.log
+ CLEANFILES = $(DISTCLEANFILES) stamp-h1
+diff -Nru ntop-3.3.10.orig/configure.in ntop-3.3.10/configure.in
+--- ntop-3.3.10.orig/configure.in 2009-05-06 14:55:22.000000000 +0000
++++ ntop-3.3.10/configure.in 2009-06-14 09:48:54.000000000 +0000
+@@ -57,6 +57,7 @@
+ dnl>
+ umask 002
+ AM_CONFIG_HEADER(config.h)
++AM_MAINTAINER_MODE
+
+ HAS_ERROR=
+ HAS_WARNING=
+@@ -507,11 +508,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/ /opt/local
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+diff -Nru ntop-3.3.10.orig/globals-core.c ntop-3.3.10/globals-core.c
+--- ntop-3.3.10.orig/globals-core.c 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/globals-core.c 2009-06-14 09:47:43.000000000 +0000
+@@ -386,7 +386,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+diff -Nru ntop-3.3.10.orig/report.c ntop-3.3.10/report.c
+--- ntop-3.3.10.orig/report.c 2009-05-21 21:55:11.000000000 +0000
++++ ntop-3.3.10/report.c 2009-06-14 09:47:43.000000000 +0000
+@@ -2305,7 +2305,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+