summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRay Russell Reese III <anti@gentoo.org>2004-02-08 19:26:36 +0000
committerRay Russell Reese III <anti@gentoo.org>2004-02-08 19:26:36 +0000
commit6b650339486175914d83295e330c24b63ed0fbee (patch)
tree0310554c0aff4dfca022de0be779860db9c15c1f /net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch
parentMarking x86. Fixes lots of issues like SMP, module-init-tools, etc (diff)
downloadhistorical-6b650339486175914d83295e330c24b63ed0fbee.tar.gz
historical-6b650339486175914d83295e330c24b63ed0fbee.tar.bz2
historical-6b650339486175914d83295e330c24b63ed0fbee.zip
Initial Import
Diffstat (limited to 'net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch')
-rw-r--r--net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch91
1 files changed, 91 insertions, 0 deletions
diff --git a/net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch b/net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch
new file mode 100644
index 000000000000..ad7001a64e84
--- /dev/null
+++ b/net-analyzer/rtg/files/rtg-0.7.4-pathfix.patch
@@ -0,0 +1,91 @@
+diff -ruN ./rtg-0.7.4.orig/contrib/Makefile.in ./rtg-0.7.4/contrib/Makefile.in
+--- ./rtg-0.7.4.orig/contrib/Makefile.in 2004-02-08 13:52:20.361020339 -0500
++++ ./rtg-0.7.4/contrib/Makefile.in 2004-02-08 13:52:33.854805146 -0500
+@@ -80,7 +80,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+
+-contribdir = $(prefix)/contrib
++contribdir = $(datadir)/rtg/contrib
+ contrib_DATA = README rtgtargmkr-with-modules-0.2.tar.gz
+ EXTRA_DIST = $(contrib_DATA)
+ subdir = contrib
+diff -ruN ./rtg-0.7.4.orig/etc/Makefile.in ./rtg-0.7.4/etc/Makefile.in
+--- ./rtg-0.7.4.orig/etc/Makefile.in 2004-02-08 13:52:20.331025263 -0500
++++ ./rtg-0.7.4/etc/Makefile.in 2004-02-08 13:52:33.854805146 -0500
+@@ -220,14 +220,13 @@
+ all:
+
+ install: installdirs
+- @for i in $(ETC) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(etcdir) ; echo "install: installed $$i in $(prefix)$(etcdir)" ; done
+- @for i in $(WEB) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(webdir) ; echo "install: installed $$i in $(prefix)$(webdir)" ; done
+- @for i in $(REPORTS) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(reportsdir) ; echo "install: installed $$i in $(prefix)$(reportsdir)" ; done
++ @for i in $(ETC) ; do $(INSTALL) $(srcdir)/$$i $(sysconfdir)/rtg ; echo "install: installed $$i in $(sysconfdir)" ; done
++ @for i in $(WEB) ; do $(INSTALL) $(srcdir)/$$i $(datadir)/rtg ; echo "install: installed $$i in $(datadir)" ; done
++ @for i in $(REPORTS) ; do $(INSTALL) $(srcdir)/$$i $(datadir)/rtg ; echo "install: installed $$i in $(datadir)" ; done
+
+ installdirs:
+- $(mkinstalldirs) $(prefix)$(etcdir)
+- $(mkinstalldirs) $(prefix)$(webdir)
+- $(mkinstalldirs) $(prefix)$(reportsdir)
++ $(mkinstalldirs) $(sysconfdir)/rtg
++ $(mkinstalldirs) $(datadir)/rtg
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+diff -ruN ./rtg-0.7.4.orig/src/Makefile.in ./rtg-0.7.4/src/Makefile.in
+--- ./rtg-0.7.4.orig/src/Makefile.in 2004-02-08 13:52:20.360020503 -0500
++++ ./rtg-0.7.4/src/Makefile.in 2004-02-08 13:52:33.855804981 -0500
+@@ -206,12 +206,12 @@
+ uninstall-info-am:
+ install-includeHEADERS: $(include_HEADERS)
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(includedir)
++ $(mkinstalldirs) $(DESTDIR)$(includedir)/rtg
+ @list='$(include_HEADERS)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(INSTALL_HEADER) $$d$$p $(DESTDIR)$(includedir)/$$f"; \
+- $(INSTALL_HEADER) $$d$$p $(DESTDIR)$(includedir)/$$f; \
++ echo " $(INSTALL_HEADER) $$d$$p $(DESTDIR)$(includedir)/rtg/$$f"; \
++ $(INSTALL_HEADER) $$d$$p $(DESTDIR)$(includedir)/rtg/$$f; \
+ done
+
+ uninstall-includeHEADERS:
+diff -ruN ./rtg-0.7.4.orig/src/rtg.h ./rtg-0.7.4/src/rtg.h
+--- ./rtg-0.7.4.orig/src/rtg.h 2004-02-08 13:52:20.360020503 -0500
++++ ./rtg-0.7.4/src/rtg.h 2004-02-08 13:52:56.912020385 -0500
+@@ -25,9 +25,10 @@
+
+ /* Define CONFIG_PATHS places to search for the rtg.conf file. Note
+ that RTG_HOME, as determined during autoconf is one path */
+-#define CONFIG_PATHS 3
++#define CONFIG_PATHS 4
+ #define CONFIG_PATH_1 ""
+ #define CONFIG_PATH_2 "/etc/"
++#define CONFIG_PATH_3 "/etc/rtg/"
+
+ /* Defaults */
+ #define DEFAULT_CONF_FILE "rtg.conf"
+@@ -44,7 +45,7 @@
+ #define DEFAULT_SNMP_PORT 161
+
+ /* PID File */
+-#define PIDFILE "/tmp/rtgpoll.pid"
++#define PIDFILE "/var/run/rtgpoll.pid"
+
+ #define STAT_DESCRIP_ERROR 99
+ #define HASHSIZE 5000
+diff -ruN ./rtg-0.7.4.orig/src/rtgutil.c ./rtg-0.7.4/src/rtgutil.c
+--- ./rtg-0.7.4.orig/src/rtgutil.c 2004-02-08 13:52:20.360020503 -0500
++++ ./rtg-0.7.4/src/rtgutil.c 2004-02-08 13:52:33.857804653 -0500
+@@ -115,7 +115,8 @@
+ set->verbose = OFF;
+ strncpy(config_paths[0], CONFIG_PATH_1, sizeof(config_paths[0]));
+ snprintf(config_paths[1], sizeof(config_paths[1]), "%s/etc/", RTG_HOME);
+- strncpy(config_paths[2], CONFIG_PATH_2, sizeof(config_paths[1]));
++ strncpy(config_paths[2], CONFIG_PATH_2, sizeof(config_paths[2]));
++ strncpy(config_paths[3], CONFIG_PATH_3, sizeof(config_paths[3]));
+ return;
+ }
+