summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-06-01 22:26:33 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-06-01 22:26:33 +0000
commit02762ce47f6323a36d082c8f66cd708726c5699f (patch)
tree505526c3f79628019a47cd1ad8b314df1bace135 /net-analyzer/rtg/rtg-0.7.4-r2.ebuild
parentChange xpdfrc paths, thanks to Ulf <fly-a-lot@web.de> in bug 134537, and add ... (diff)
downloadhistorical-02762ce47f6323a36d082c8f66cd708726c5699f.tar.gz
historical-02762ce47f6323a36d082c8f66cd708726c5699f.tar.bz2
historical-02762ce47f6323a36d082c8f66cd708726c5699f.zip
Fixing init.d wrt bug #130298 and cleaning up
Package-Manager: portage-2.1_rc1-r3
Diffstat (limited to 'net-analyzer/rtg/rtg-0.7.4-r2.ebuild')
-rw-r--r--net-analyzer/rtg/rtg-0.7.4-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/rtg/rtg-0.7.4-r2.ebuild b/net-analyzer/rtg/rtg-0.7.4-r2.ebuild
new file mode 100644
index 000000000000..95b726e56b49
--- /dev/null
+++ b/net-analyzer/rtg/rtg-0.7.4-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/rtg-0.7.4-r2.ebuild,v 1.1 2006/06/01 22:26:33 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="RTG: Real Traffic Grabber"
+HOMEPAGE="http://rtg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-db/mysql-3.23.52-r1
+ >=net-analyzer/net-snmp-5.0.9-r1"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-pathfix.patch
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/rtg \
+ --datadir=/usr/share/rtg \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc FAQ README
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/rtgpoll.confd rtgpoll
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rtgpoll.initd rtgpoll
+}
+
+pkg_postinst() {
+ einfo "RTG has been installed."
+ einfo
+ einfo "The default configuration file location is now /etc/rtg"
+ einfo
+ einfo "Sample reports have been installed into /usr/share/rtg"
+ einfo
+}