summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-06-04 20:17:14 +0000
committerSven Wegener <swegener@gentoo.org>2005-06-04 20:17:14 +0000
commit09832b616d5b55b70efa0a8ba6b9d712f758d14a (patch)
tree2979ffd73fdb51666f3efd20704a1524c21157c8 /net-analyzer/thrulay
parentcosmectic changes (diff)
downloadhistorical-09832b616d5b55b70efa0a8ba6b9d712f758d14a.tar.gz
historical-09832b616d5b55b70efa0a8ba6b9d712f758d14a.tar.bz2
historical-09832b616d5b55b70efa0a8ba6b9d712f758d14a.zip
Added cross-compile support and error checking.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-analyzer/thrulay')
-rw-r--r--net-analyzer/thrulay/ChangeLog5
-rw-r--r--net-analyzer/thrulay/Manifest4
-rw-r--r--net-analyzer/thrulay/thrulay-0.6.ebuild17
3 files changed, 15 insertions, 11 deletions
diff --git a/net-analyzer/thrulay/ChangeLog b/net-analyzer/thrulay/ChangeLog
index e0bd677e8379..267ba98f3318 100644
--- a/net-analyzer/thrulay/ChangeLog
+++ b/net-analyzer/thrulay/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/thrulay
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/ChangeLog,v 1.1 2005/06/04 19:28:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/ChangeLog,v 1.2 2005/06/04 20:17:14 swegener Exp $
+
+ 04 Jun 2005; Sven Wegener <swegener@gentoo.org> thrulay-0.6.ebuild:
+ Added cross-compile support and error checking.
*thrulay-0.6 (04 Jun 2005)
diff --git a/net-analyzer/thrulay/Manifest b/net-analyzer/thrulay/Manifest
index 57ad984c33f8..ddd971ec2644 100644
--- a/net-analyzer/thrulay/Manifest
+++ b/net-analyzer/thrulay/Manifest
@@ -1,5 +1,5 @@
-MD5 a14b530f02673ba9fce5ab2f2fed33b5 thrulay-0.6.ebuild 702
-MD5 530bc6f887d53e53940230d6d00359ef ChangeLog 446
+MD5 00c515235977e8fa7aa736a93b33e02e thrulay-0.6.ebuild 875
+MD5 ab5382267181eee7ec36795f155f82d1 ChangeLog 568
MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
MD5 22c6b7ad0b49aeb367c0160abcb9d894 files/thrulayd-init.d 674
MD5 0df0073ca802c6d7e563f1d6976c1b76 files/digest-thrulay-0.6 62
diff --git a/net-analyzer/thrulay/thrulay-0.6.ebuild b/net-analyzer/thrulay/thrulay-0.6.ebuild
index 71e8541cf995..8b20eb0c5b03 100644
--- a/net-analyzer/thrulay/thrulay-0.6.ebuild
+++ b/net-analyzer/thrulay/thrulay-0.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/thrulay-0.6.ebuild,v 1.1 2005/06/04 19:28:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/thrulay-0.6.ebuild,v 1.2 2005/06/04 20:17:14 swegener Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Measure the capacity of a network by sending a bulk TCP stream over it."
HOMEPAGE="http://www.internet2.edu/~shalunov/thrulay/"
@@ -10,16 +12,15 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
DEPEND=""
-#RDEPEND=""
src_compile() {
- emake OPT="${CFLAGS}"
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}" || die "emake failed"
}
src_install() {
- dobin thrulay
- dosbin thrulayd
- dodoc LICENSE README TODO thrulay-protocol.txt
- newinitd ${FILESDIR}/thrulayd-init.d thrulayd
- newconfd ${FILESDIR}/thrulayd-conf.d thrulayd
+ dobin thrulay || die "dobin failed"
+ dosbin thrulayd || die "dosbin failed"
+ dodoc LICENSE README TODO thrulay-protocol.txt || die "dodoc failed"
+ newinitd "${FILESDIR}"/thrulayd-init.d thrulayd || die "newinitd failed"
+ newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd || die "newconfd failed"
}