summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 11:17:08 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 11:17:08 +0000
commit022ed127f9569d983339c61b6c130239d420a655 (patch)
treebef59be067577766e464d29b7b24367acf8f1c32 /net-analyzer/trafd
parentsed fixes and other misc. (diff)
downloadhistorical-022ed127f9569d983339c61b6c130239d420a655.tar.gz
historical-022ed127f9569d983339c61b6c130239d420a655.tar.bz2
historical-022ed127f9569d983339c61b6c130239d420a655.zip
sed expression fixes and other misc.
Diffstat (limited to 'net-analyzer/trafd')
-rw-r--r--net-analyzer/trafd/ChangeLog9
-rw-r--r--net-analyzer/trafd/files/digest-trafd-3.0.11
-rw-r--r--net-analyzer/trafd/trafd-3.0.1.ebuild27
3 files changed, 23 insertions, 14 deletions
diff --git a/net-analyzer/trafd/ChangeLog b/net-analyzer/trafd/ChangeLog
index 4447c3a648fb..78e0cefc3188 100644
--- a/net-analyzer/trafd/ChangeLog
+++ b/net-analyzer/trafd/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for net-analyzer/trafd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafd/ChangeLog,v 1.1 2002/11/08 13:07:26 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafd/ChangeLog,v 1.2 2003/02/10 11:17:08 seemant Exp $
*trafd-3.0.1 (08 Nov 2002)
+ 10 Feb 2003; Seemant Kulleen <seemant@gentoo.org> trafd-3.0.1.ebuild :
+
+ Moved the config, initscript and patch into a tarball onto the mirrors
+ and out of files/. Also, changed the sed expression delimiters from / to
+ :, closing bug #15006 by Blu3 <david+gentoo.org@blue-labs.org>
+
+
08 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
Initial import. Ebuild contributed by Asen Kurin <asen@warlock.ru> in #8446.
diff --git a/net-analyzer/trafd/files/digest-trafd-3.0.1 b/net-analyzer/trafd/files/digest-trafd-3.0.1
index 4a9e62474d32..d8807af52037 100644
--- a/net-analyzer/trafd/files/digest-trafd-3.0.1
+++ b/net-analyzer/trafd/files/digest-trafd-3.0.1
@@ -1,2 +1,3 @@
MD5 6a5abb246e95b68f0d53ebf789bda4fb trafd-3.0.1.tgz 35365
MD5 c61d8f5b9824763bd5b93708048f4727 tcpdump-richard-1.7.tar.gz 198587
+MD5 b8d3022e86dc2e47ef2e81e21e5de22e trafd-3.0.1-gentoo.tar.bz2 2600
diff --git a/net-analyzer/trafd/trafd-3.0.1.ebuild b/net-analyzer/trafd/trafd-3.0.1.ebuild
index ce78e3c9a90e..51805951d6a2 100644
--- a/net-analyzer/trafd/trafd-3.0.1.ebuild
+++ b/net-analyzer/trafd/trafd-3.0.1.ebuild
@@ -1,14 +1,19 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafd/trafd-3.0.1.ebuild,v 1.1 2002/11/08 13:07:26 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafd/trafd-3.0.1.ebuild,v 1.2 2003/02/10 11:17:08 seemant Exp $
+
+inherit eutils
S=${WORKDIR}/${P}
DESCRIPTION="The BPF Traffic Collector"
SRC_URI="ftp://ftp.riss-telecom.ru/pub/dev/trafd/${P}.tgz
- http://metalab.unc.edu/pub/Linux/system/network/management/tcpdump-richard-1.7.tar.gz"
+ http://metalab.unc.edu/pub/Linux/system/network/management/tcpdump-richard-1.7.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2
+ http://cvs.gentoo.org/~seemant/${P}-gentoo.tar.bz2"
HOMEPAGE="ftp://ftp.riss-telecom.ru/pub/dev/trafd/"
-LICENSE="BSD"
+
SLOT="0"
+LICENSE="BSD"
KEYWORDS="~x86"
# -lbpft/*Ó×ÏÑ*/ -lpcap -lcurses -ltermcap -lfl
@@ -16,26 +21,22 @@ DEPEND="net-libs/libpcap
sys-libs/ncurses
sys-devel/flex"
-RDEPEND=$DEPEND
+PATCHDIR=${WORKDIR}/${P}-gentoo
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${PATCHDIR}/${PF}-gentoo.diff
mv Makefile Makefile.orig
- sed "44s/-O2$/${CFLAGS}/" Makefile.orig >Makefile
-}
-
-src_compile() {
- emake || die
+ sed "44s:-O2$:${CFLAGS}:" Makefile.orig >Makefile
}
src_install () {
dodir /usr/bin /etc /usr/share/doc/trafd-3.0.1 /var/trafd
make install DESTDIR=${D} || die
- exeinto /etc/init.d ; newexe ${FILESDIR}/trafd.init trafd
- insinto /etc/conf.d ; newins ${FILESDIR}/trafd.conf trafd
+ exeinto /etc/init.d ; newexe ${PATCHDIR}/trafd.init trafd
+ insinto /etc/conf.d ; newins ${PATCHDIR}/trafd.conf trafd
}
pkg_postinst() {