summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-11-23 22:07:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-11-23 22:07:44 +0000
commit263dd3e858de430c6283ccfa972a8fc7cafa1cc5 (patch)
tree2032b7fd2946b8faaeae53891dc5362be287207e /net-analyzer
parentVersion bumped to latest version. (diff)
downloadhistorical-263dd3e858de430c6283ccfa972a8fc7cafa1cc5.tar.gz
historical-263dd3e858de430c6283ccfa972a8fc7cafa1cc5.tar.bz2
historical-263dd3e858de430c6283ccfa972a8fc7cafa1cc5.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ipaudit/ChangeLog10
-rw-r--r--net-analyzer/ipaudit/Manifest3
-rw-r--r--net-analyzer/ipaudit/files/digest-ipaudit-1.0_beta11
-rw-r--r--net-analyzer/ipaudit/ipaudit-1.0_beta1.ebuild27
4 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/ipaudit/ChangeLog b/net-analyzer/ipaudit/ChangeLog
new file mode 100644
index 000000000000..13881bc9b844
--- /dev/null
+++ b/net-analyzer/ipaudit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/ipaudit
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipaudit/ChangeLog,v 1.1 2004/11/23 22:07:44 robbat2 Exp $
+
+*ipaudit-1.0_beta1 (23 Nov 2004)
+
+ 23 Nov 2004; Robin H. Johnson <robbat2@gentoo.org>
+ +ipaudit-1.0_beta1.ebuild:
+ Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>
+
diff --git a/net-analyzer/ipaudit/Manifest b/net-analyzer/ipaudit/Manifest
new file mode 100644
index 000000000000..4461a9b73097
--- /dev/null
+++ b/net-analyzer/ipaudit/Manifest
@@ -0,0 +1,3 @@
+MD5 789e8354f1835a447324fe82019e94a6 ipaudit-1.0_beta1.ebuild 753
+MD5 f36c0cdfb884f866ea0710395b701224 ChangeLog 397
+MD5 276e07ebd117b9c60ef6fa7d5316b0b9 files/digest-ipaudit-1.0_beta1 68
diff --git a/net-analyzer/ipaudit/files/digest-ipaudit-1.0_beta1 b/net-analyzer/ipaudit/files/digest-ipaudit-1.0_beta1
new file mode 100644
index 000000000000..d70a2b629983
--- /dev/null
+++ b/net-analyzer/ipaudit/files/digest-ipaudit-1.0_beta1
@@ -0,0 +1 @@
+MD5 3e84ade8c2adb52c644e7d76a80b4a1d ipaudit-1.0BETA1.tar.gz 132549
diff --git a/net-analyzer/ipaudit/ipaudit-1.0_beta1.ebuild b/net-analyzer/ipaudit/ipaudit-1.0_beta1.ebuild
new file mode 100644
index 000000000000..5413e369e82d
--- /dev/null
+++ b/net-analyzer/ipaudit/ipaudit-1.0_beta1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipaudit/ipaudit-1.0_beta1.ebuild,v 1.1 2004/11/23 22:07:44 robbat2 Exp $
+
+inherit eutils
+DESCRIPTION="IPAudit monitors network activity on a network by host, protocol and port."
+HOMEPAGE="http://ipaudit.sourceforge.net/"
+MY_P="${PN}-${PV/_beta/BETA}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql"
+DEPEND="net-libs/libpcap
+ mysql? ( dev-db/mysql )"
+#RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf `use_with mysql` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS README
+}