summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-13 10:07:59 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-13 10:07:59 +0000
commit60e9847d574b3f708e70c110746cfaaeb7f06d59 (patch)
tree50748a77242db052a0839466f56d8d384723986a /net-analyzer
parentPut imagemagick-5.5.3.2.ebuild back to ~ppc due to dependencies masked (diff)
downloadhistorical-60e9847d574b3f708e70c110746cfaaeb7f06d59.tar.gz
historical-60e9847d574b3f708e70c110746cfaaeb7f06d59.tar.bz2
historical-60e9847d574b3f708e70c110746cfaaeb7f06d59.zip
version bump
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog9
-rw-r--r--net-analyzer/rrdtool/files/digest-rrdtool-1.0.411
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.40.ebuild4
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.41.ebuild98
4 files changed, 109 insertions, 3 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index f42989682525..a8ac17b5dbb7 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.11 2003/02/12 07:49:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.12 2003/03/13 10:07:59 absinthe Exp $
+
+*rrdtool-1.0.41 (13 Mar 2003)
+
+ 13 Mar 2003; Dylan Carlson <absinthe@gentoo.org> rrdtool-1.0.41.ebuild
+ files/digest-rrdtool-1.0.41 ChangeLog :
+
+ Version bump.
*rrdtool-1.0.40 (18 Jan 2003)
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.41 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.41
new file mode 100644
index 000000000000..69bdd9d4ea1f
--- /dev/null
+++ b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.41
@@ -0,0 +1 @@
+MD5 3559dafca2a5cd7bb81b1d2b707615df rrdtool-1.0.41.tar.gz 1152339
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild
index 33199f474d93..ddba8a45c55c 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild,v 1.5 2003/03/11 21:11:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild,v 1.6 2003/03/13 10:07:59 absinthe Exp $
inherit perl-module
@@ -10,7 +10,7 @@ HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc"
+KEYWORDS="x86 ppc sparc"
IUSE="tcltk perl"
DEPEND="perl? ( dev-lang/perl )
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.41.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.41.ebuild
new file mode 100644
index 000000000000..6b91f0a02078
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.0.41.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.41.ebuild,v 1.1 2003/03/13 10:07:59 absinthe Exp $
+
+inherit perl-module
+
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/rrdtool/pub/${P}.tar.gz"
+HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="tcltk perl"
+
+DEPEND="perl? ( dev-lang/perl )
+ sys-apps/gawk
+ >=media-libs/libgd-1.8.3"
+RDEPEND="tcltk? ( dev-lang/tcl )"
+
+TCLVER=""
+
+pkg_setup() {
+ use tcltk && \
+ TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
+
+ use perl && perl-post_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ use tcltk \
+ && myconf="${myconf} --with-tcllib=/usr/lib" \
+ || myconf="${myconf} --without-tcllib"
+
+ econf \
+ --datadir=/usr/share \
+ --enable-shared \
+ --with-perl-options='INSTALLMAN1DIR=/usr/share/man/man1 INSTALLMAN3DIR=/usr/share/man/man3 PREFIX=${D}/usr' \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ # this package completely ignores mandir settings
+
+ doman doc/*.1
+ dohtml doc/*.html
+ dodoc doc/*.pod
+ dodoc doc/*.txt
+
+ rm -rf ${D}/usr/doc
+ rm -rf ${D}/usr/html
+ rm -rf ${D}/usr/man
+ rm -rf ${D}/usr/contrib
+ rm -rf ${D}/usr/examples
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*
+
+ if [ `use perl` ] ; then
+ perl-post_perlinfo
+ mytargets="site-perl-install"
+ perl-module_src_install || die
+ fi
+
+ if [ `use tcltk` ] ; then
+ mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
+ insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
+ doins ${S}/tcl/tclrrd${PV}.so
+ echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
+ >> ${D}/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
+ fi
+
+ dodoc CHANGES COPY* CONTR* README TODO
+}
+
+
+pkg_preinst() {
+ use perl && perl-post_pkg_preinst
+}
+
+pkg_postinst() {
+ use perl && perl-post_pkg_postinst
+}
+
+pkg_prerm() {
+ use perl && perl-post_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-post_pkg_postrm
+}