summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:39:30 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:39:30 +0000
commita3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0 (patch)
tree47271b33fc38eb594e60de9a69efe552ed264377 /net-dialup/fcpci
parentMarking gnustep ppc for bug 207381 (diff)
downloadhistorical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.tar.gz
historical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.tar.bz2
historical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.zip
fixing string.h problem (see bug #202385).
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-dialup/fcpci')
-rw-r--r--net-dialup/fcpci/ChangeLog7
-rw-r--r--net-dialup/fcpci/fcpci-0.1-r1.ebuild57
-rw-r--r--net-dialup/fcpci/files/digest-fcpci-0.1-r13
3 files changed, 66 insertions, 1 deletions
diff --git a/net-dialup/fcpci/ChangeLog b/net-dialup/fcpci/ChangeLog
index 7cd2e6481fdf..686a8d734baf 100644
--- a/net-dialup/fcpci/ChangeLog
+++ b/net-dialup/fcpci/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/fcpci
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.18 2008/01/06 01:54:37 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.19 2008/01/30 01:36:37 sbriesen Exp $
+
+*fcpci-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org> +fcpci-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385).
06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
-fcpci-3.11.02-r2.ebuild:
diff --git a/net-dialup/fcpci/fcpci-0.1-r1.ebuild b/net-dialup/fcpci/fcpci-0.1-r1.ebuild
new file mode 100644
index 000000000000..94f77deb5373
--- /dev/null
+++ b/net-dialup/fcpci/fcpci-0.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/fcpci-0.1-r1.ebuild,v 1.1 2008/01/30 01:36:37 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ local BIT="" PAT="01234"
+ if use amd64; then
+ BIT="64bit-" PAT="1234"
+ fi
+
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-${BIT}[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[${PAT}]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcpci/files/digest-fcpci-0.1-r1 b/net-dialup/fcpci/files/digest-fcpci-0.1-r1
new file mode 100644
index 000000000000..8ea388c05cdf
--- /dev/null
+++ b/net-dialup/fcpci/files/digest-fcpci-0.1-r1
@@ -0,0 +1,3 @@
+MD5 6347f341489383ea543c302c0b8cd230 fcpci-0.1-0.src.rpm 1418928
+RMD160 b74bc1e9acaa38c4366951a6c2b41387ba7a0bd8 fcpci-0.1-0.src.rpm 1418928
+SHA256 72588c1efaf4572ca8dbf3c53b0a3e496518d042f004db29764af2777677a485 fcpci-0.1-0.src.rpm 1418928