summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-12-27 09:12:16 +0000
committerAlin Năstac <mrness@gentoo.org>2007-12-27 09:12:16 +0000
commit36e00f00c978c58c2f29fd6f67bbff7aa4c3f41c (patch)
tree0a450911ed31e494b8f366282cf12fa421bec1e7 /net-dialup/minicom/minicom-2.2-r1.ebuild
parentupdated gnatbuild.eclass to support primary compilers (#151343) (diff)
downloadhistorical-36e00f00c978c58c2f29fd6f67bbff7aa4c3f41c.tar.gz
historical-36e00f00c978c58c2f29fd6f67bbff7aa4c3f41c.tar.bz2
historical-36e00f00c978c58c2f29fd6f67bbff7aa4c3f41c.zip
Added nls support (#203225).
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-dialup/minicom/minicom-2.2-r1.ebuild')
-rw-r--r--net-dialup/minicom/minicom-2.2-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/net-dialup/minicom/minicom-2.2-r1.ebuild b/net-dialup/minicom/minicom-2.2-r1.ebuild
index 62175eb908ff..7a01ce45f658 100644
--- a/net-dialup/minicom/minicom-2.2-r1.ebuild
+++ b/net-dialup/minicom/minicom-2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.2-r1.ebuild,v 1.12 2007/06/24 22:05:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.2-r1.ebuild,v 1.13 2007/12/27 09:12:16 mrness Exp $
inherit eutils
@@ -13,12 +13,19 @@ SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
-IUSE=""
+IUSE="nls"
-DEPEND=">=sys-libs/ncurses-5.2-r3"
-RDEPEND="${DEPEND}
+COMM0N_DEPEND="sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${COMMON_DEPEND}
net-dialup/lrzsz"
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs da de es fi fr hu ja no pl pt_BR ro ru rw sv vi zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -27,7 +34,9 @@ src_unpack() {
}
src_compile() {
- econf --sysconfdir=/etc/${PN} || die "econf failed"
+ econf --sysconfdir=/etc/${PN} \
+ $(use_enable nls) \
+ || die "econf failed"
emake || die "emake failed"
}