summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-23 17:35:13 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-23 17:35:13 +0000
commit6f2047525741ad91589253e7604ad14f333d648b (patch)
treee72502eb52eb0a19c3e6a630193a22727c9f0397 /net-dialup
parentnew version (diff)
downloadhistorical-6f2047525741ad91589253e7604ad14f333d648b.tar.gz
historical-6f2047525741ad91589253e7604ad14f333d648b.tar.bz2
historical-6f2047525741ad91589253e7604ad14f333d648b.zip
Fixes some makefile issues (#1988)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/mgetty/ChangeLog9
-rw-r--r--net-dialup/mgetty/files/digest-mgetty-1.1.26-r31
-rw-r--r--net-dialup/mgetty/mgetty-1.1.26-r3.ebuild94
3 files changed, 103 insertions, 1 deletions
diff --git a/net-dialup/mgetty/ChangeLog b/net-dialup/mgetty/ChangeLog
index 794c7922c1f2..1405c87732cd 100644
--- a/net-dialup/mgetty/ChangeLog
+++ b/net-dialup/mgetty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/mgetty
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.2 2002/04/14 21:45:23 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.3 2002/04/23 17:35:13 rphillips Exp $
+
+*mgetty-1.1.26-r2 (23 Apr 2002)
+
+ 23 Apr 2002; R.Phillips <rphillips@gentoo.org> mgetty-1.1.26-r3.ebuild :
+
+ Fixes variables passed to the makefile and activates Calling Number
+ Display (CND). Fixes (#1988)
*mgetty-1.1.26-r2 (14 Apr 2002)
diff --git a/net-dialup/mgetty/files/digest-mgetty-1.1.26-r3 b/net-dialup/mgetty/files/digest-mgetty-1.1.26-r3
new file mode 100644
index 000000000000..b869bfcfff40
--- /dev/null
+++ b/net-dialup/mgetty/files/digest-mgetty-1.1.26-r3
@@ -0,0 +1 @@
+MD5 02d60e05acdd406b1e86222e8a373a7e mgetty1.1.26-Apr16.tar.gz 948245
diff --git a/net-dialup/mgetty/mgetty-1.1.26-r3.ebuild b/net-dialup/mgetty/mgetty-1.1.26-r3.ebuild
new file mode 100644
index 000000000000..1f6c89ea17fc
--- /dev/null
+++ b/net-dialup/mgetty/mgetty-1.1.26-r3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# Updated by Todd Wright <wylie@geekasylum.org> -r3
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Fax and Voice modem programs."
+
+SRC_URI="ftp://alpha.greenie.net/pub/mgetty/source/1.1/${PN}${PV}-Apr16.tar.gz"
+HOMEPAGE="http://alpha.greenie.net/mgetty"
+
+DEPEND="sys-libs/glibc
+ app-text/tetex
+ sys-apps/gawk
+ sys-devel/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/doc
+ patch -p0 < ${FILESDIR}/mgetty-${PV}-gentoo.diff || die
+
+ cp Makefile Makefile.orig
+ sed -e "s:dvips -o mgetty.ps:dvips -M -o mgetty.ps:" \
+ Makefile.orig >Makefile
+
+ cd ${S}
+ sed -e 's:var/log/mgetty:var/log/mgetty/mgetty:' \
+ -e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
+ -e 's:\/\* \#define CNDFILE "dialin.config" \*\/:\#define CNDFILE "dialin.config":' \
+ policy.h-dist > policy.h
+}
+
+src_compile() {
+ mycflags="${CFLAGS}"
+ unset CFLAGS
+ emake prefix=/usr \
+ CONFDIR=/etc/mgetty+sendfax \
+ CFLAGS="${mycflags}" \
+ || die
+ cd voice
+ emake CONFDIR=/etc/mgetty+sendfax \
+ CFLAGS="${mycflags}" \
+ || die
+ cd ${S}
+}
+
+src_install () {
+ dodir /var/spool
+ dodir /usr/share/info
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ CONFDIR=${D}/etc/mgetty+sendfax \
+ spool=${D}/var/spool \
+ install || die
+
+ cd voice
+ make prefix=${D}/usr \
+ CONFDIR=${D}/etc/mgetty+sendfax \
+ install || die
+
+ cd ${S}
+ dodoc BUGS ChangeLog FTP README.1st Recommend THANKS TODO
+ cd doc
+ dodoc *.txt modems.db mgetty.ps
+
+ #generate missing fonts if any.
+ if [ -f ${S}/doc/missfont.log ]
+ then
+ echo '#!/bin/bash' >genfonts.sh
+ cat missfont.log >>genfonts.sh
+ chmod +x genfonts.sh
+ dodoc genfonts.sh
+ fi
+}
+
+pkg_postinst() {
+ #generate missing fonts if any.
+ if [ -x {$ROOT}/usr/share/doc/${PF}/genfonts.sh ]
+ then
+ {$ROOT}/usr/share/doc/${PF}/genfonts.sh
+ fi
+
+ if [ ! -d ${ROOT}/var/spool/fax/incoming ]
+ then
+ mkdir -p ${ROOT}/var/spool/fax/incoming
+ fi
+ if [ ! -d ${ROOT}/var/spool/fax/outgoing/locks ]
+ then
+ mkdir -p ${ROOT}/var/spool/fax/outgoing/locks
+ fi
+}
+