summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-30 20:54:12 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-30 20:54:12 +0000
commitbc22e7ff96b63631a4e448b5ebfb1da66fddce3f (patch)
tree0d51875a4bc5b08568315e9140929f6fc4d469c3 /net-dialup
parentAdded patch that allows to compile on systems with broken fnmatch function (l... (diff)
downloadhistorical-bc22e7ff96b63631a4e448b5ebfb1da66fddce3f.tar.gz
historical-bc22e7ff96b63631a4e448b5ebfb1da66fddce3f.tar.bz2
historical-bc22e7ff96b63631a4e448b5ebfb1da66fddce3f.zip
Initial import from bug #134029.
Package-Manager: portage-2.0.54-r2
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/ChangeLog10
-rw-r--r--net-dialup/xl2tpd/Manifest15
-rw-r--r--net-dialup/xl2tpd/files/digest-xl2tpd-1.041
-rw-r--r--net-dialup/xl2tpd/files/l2tpd-init32
-rw-r--r--net-dialup/xl2tpd/metadata.xml6
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.04.ebuild31
6 files changed, 95 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
new file mode 100644
index 000000000000..010fce269fff
--- /dev/null
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/xl2tpd
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+*xl2tpd-1.04 (30 May 2006)
+
+ 30 May 2006; Alin Nastac <mrness@gentoo.org> +files/l2tpd-init,
+ +metadata.xml, +xl2tpd-1.04.ebuild:
+ Initial import from bug #134029, thanks to Alexandre Ghisoli <alex@ghisoli.ch>.
+
diff --git a/net-dialup/xl2tpd/Manifest b/net-dialup/xl2tpd/Manifest
new file mode 100644
index 000000000000..ae46b3665027
--- /dev/null
+++ b/net-dialup/xl2tpd/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6d44dde40a3d062edc266137af3251fa ChangeLog 422
+MD5 c0494910abd2a9c98e958d5b764d4d0b files/digest-xl2tpd-1.04 63
+MD5 e9f9b7f11f160180074c80fc8e3ba42d files/l2tpd-init 719
+MD5 2489971def1ce6f019a703c6b877a124 metadata.xml 281
+MD5 c1f0801f8bcd1453960a77726f031864 xl2tpd-1.04.ebuild 835
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.2 (GNU/Linux)
+
+iD8DBQFEfLEEjG8pv1lIUX4RAoPxAJ4zNDg1Lul4fOdI7aCyBmSiofChhwCeI43/
+IEXswqTzN2mPRDpIiebto44=
+=skFO
+-----END PGP SIGNATURE-----
diff --git a/net-dialup/xl2tpd/files/digest-xl2tpd-1.04 b/net-dialup/xl2tpd/files/digest-xl2tpd-1.04
new file mode 100644
index 000000000000..06dc4f677b24
--- /dev/null
+++ b/net-dialup/xl2tpd/files/digest-xl2tpd-1.04
@@ -0,0 +1 @@
+MD5 36220cff74221fff461d93c9334adbb1 xl2tpd-1.04.tar.gz 138139
diff --git a/net-dialup/xl2tpd/files/l2tpd-init b/net-dialup/xl2tpd/files/l2tpd-init
new file mode 100644
index 000000000000..b118736cc36b
--- /dev/null
+++ b/net-dialup/xl2tpd/files/l2tpd-init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/files/l2tpd-init,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [[ ! -f /etc/l2tpd/l2tpd.conf ]] ; then
+ eerror "Missing /etc/l2tpd/l2tpd.conf configuration file!"
+ eerror "Example configuration file could be found in doc directory."
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting l2tpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/l2tpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping l2tpd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/l2tpd.pid
+ eend $?
+}
diff --git a/net-dialup/xl2tpd/metadata.xml b/net-dialup/xl2tpd/metadata.xml
new file mode 100644
index 000000000000..eb06d7f5b8ea
--- /dev/null
+++ b/net-dialup/xl2tpd/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>The Layer 2 Tunneling Protocol (L2TP) daemon mantained by Xelerance Corporation.</longdescription>
+</pkgmetadata>
diff --git a/net-dialup/xl2tpd/xl2tpd-1.04.ebuild b/net-dialup/xl2tpd/xl2tpd-1.04.ebuild
new file mode 100644
index 000000000000..0c14ede66136
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.04.ebuild,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="http://www.xelerance.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-dialup/l2tpd
+ net-dialup/ppp"
+
+S="${WORKDIR}/xl2tp-${PV}"
+
+src_install() {
+ dosbin l2tpd
+ doman doc/*.[85]
+
+ dodoc BUGS CHANGELOG CREDITS README TODO \
+ doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/l2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/l2tpd/l2tp-secrets"
+ fperms 0600 /etc/l2tpd/l2tp-secrets
+
+ newinitd "${FILESDIR}/l2tpd-init" l2tpd
+}