summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-08-13 04:36:23 +0000
committerPeter Volkov <pva@gentoo.org>2008-08-13 04:36:23 +0000
commite2068dc1889005eb7e2bcb87d92a1f07a411c047 (patch)
tree9dd59a1d616379c13b709cb3b6cbbe93cddd08dd /net-firewall/ebtables/files
parentVerbump (diff)
downloadhistorical-e2068dc1889005eb7e2bcb87d92a1f07a411c047.tar.gz
historical-e2068dc1889005eb7e2bcb87d92a1f07a411c047.tar.bz2
historical-e2068dc1889005eb7e2bcb87d92a1f07a411c047.zip
Fixed bug #233190, thank Suertreus for report. Also make ebtables respect LDFLAGS.
Package-Manager: portage-2.2_rc7/cvs/Linux 2.6.22-ovz005 i686
Diffstat (limited to 'net-firewall/ebtables/files')
-rw-r--r--net-firewall/ebtables/files/ebtables-v2.0.8-2-LDFLAGS.diff54
-rw-r--r--net-firewall/ebtables/files/ebtables-v2.0.8-2-ethertype-DESTDIR-mkdir.patch40
2 files changed, 94 insertions, 0 deletions
diff --git a/net-firewall/ebtables/files/ebtables-v2.0.8-2-LDFLAGS.diff b/net-firewall/ebtables/files/ebtables-v2.0.8-2-LDFLAGS.diff
new file mode 100644
index 000000000000..f5ccb9375dbe
--- /dev/null
+++ b/net-firewall/ebtables/files/ebtables-v2.0.8-2-LDFLAGS.diff
@@ -0,0 +1,54 @@
+=== modified file 'Makefile'
+--- Makefile 2008-08-12 12:30:44 +0000
++++ Makefile 2008-08-12 12:30:56 +0000
+@@ -18,7 +18,6 @@
+ CFLAGS:=-Wall -Wunused
+ CFLAGS_SH_LIB:=-fPIC
+ CC:=gcc
+-LD:=ld
+
+ ifeq ($(shell uname -m),sparc64)
+ CFLAGS+=-DEBT_MIN_ALIGN=8 -DKERNEL_64_USERSPACE_32
+@@ -85,10 +84,10 @@
+
+ .PHONY: libebtc
+ libebtc: $(OBJECTS2)
+- $(LD) -shared -soname libebtc.so -o libebtc.so -lc $(OBJECTS2)
++ $(CC) -shared $(LDFLAGS) -Wl,-soname=libebtc.so -o libebtc.so -lc $(OBJECTS2)
+
+ ebtables: $(OBJECTS) ebtables-standalone.o libebtc
+- $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
++ $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+ -Wl,-rpath,$(LIBDIR)
+
+ ebtablesu: ebtablesu.c
+@@ -105,7 +104,7 @@
+ $(CC) $(CFLAGS) $(PROGSPECS) -c $< -o $@ -I$(KERNEL_INCLUDES)
+
+ ebtables-restore: $(OBJECTS) ebtables-restore.o libebtc
+- $(CC) $(CFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+ -Wl,-rpath,$(LIBDIR)
+
+ .PHONY: daemon
+
+=== modified file 'extensions/Makefile'
+--- extensions/Makefile 2008-08-12 12:30:44 +0000
++++ extensions/Makefile 2008-08-12 12:30:45 +0000
+@@ -11,13 +11,13 @@
+ EXT_LIBSI+=$(foreach T,$(EXT_TABLES), -lebtable_$(T))
+
+ extensions/ebt_%.so: extensions/ebt_%.o
+- $(CC) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
+
+ extensions/libebt_%.so: extensions/ebt_%.so
+ mv $< $@
+
+ extensions/ebtable_%.so: extensions/ebtable_%.o
+- $(CC) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
+
+ extensions/libebtable_%.so: extensions/ebtable_%.so
+ mv $< $@
+
diff --git a/net-firewall/ebtables/files/ebtables-v2.0.8-2-ethertype-DESTDIR-mkdir.patch b/net-firewall/ebtables/files/ebtables-v2.0.8-2-ethertype-DESTDIR-mkdir.patch
new file mode 100644
index 000000000000..310454087ee1
--- /dev/null
+++ b/net-firewall/ebtables/files/ebtables-v2.0.8-2-ethertype-DESTDIR-mkdir.patch
@@ -0,0 +1,40 @@
+=== modified file 'Makefile'
+--- Makefile 2008-08-13 04:20:07 +0000
++++ Makefile 2008-08-13 04:28:51 +0000
+@@ -153,10 +153,13 @@
+ .PHONY: scripts
+ scripts: ebtables-save ebtables.sysv ebtables-config
+ cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
++ mkdir -p $(DESTDIR)$(BINDIR)
+ install -m 0755 -o root -g root ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
+ cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
++ mkdir -p $(DESTDIR)$(INITDIR)
+ install -m 0755 -o root -g root ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
+ cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
++ mkdir -p $(DESTDIR)$(SYSCONFIGDIR)
+ install -m 0600 -o root -g root ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
+ rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
+
+@@ -166,9 +169,9 @@
+ install -m 0644 -o root -g root ebtables.8_ $(DESTDIR)$@
+ rm -f ebtables.8_
+
+-$(ETHERTYPESFILE): ethertypes
+- mkdir -p $(DESTDIR)$(@D)
+- install -m 0644 -o root -g root $< $(DESTDIR)$@
++$(DESTDIR)$(ETHERTYPESFILE): ethertypes
++ mkdir -p $(@D)
++ install -m 0644 -o root -g root $< $@
+
+ .PHONY: exec
+ exec: ebtables ebtables-restore
+@@ -177,7 +180,7 @@
+ install -m 0755 -o root -g root ebtables-restore $(DESTDIR)$(BINDIR)/ebtables-restore
+
+ .PHONY: install
+-install: $(MANDIR)/man8/ebtables.8 $(ETHERTYPESFILE) exec scripts
++install: $(MANDIR)/man8/ebtables.8 $(DESTDIR)$(ETHERTYPESFILE) exec scripts
+ mkdir -p $(DESTDIR)$(LIBDIR)
+ install -m 0755 extensions/*.so $(DESTDIR)$(LIBDIR)
+ install -m 0755 *.so $(DESTDIR)$(LIBDIR)
+