summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-03-14 19:08:05 +0000
committerPeter Johanson <latexer@gentoo.org>2005-03-14 19:08:05 +0000
commit5fe804ccc0da27f1c4cde1435a7519b9418126a0 (patch)
treee072688807d1629a1b1aa156b9d307107905985c /net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild
parentVersion bump. Closing bug #78472. (diff)
downloadhistorical-5fe804ccc0da27f1c4cde1435a7519b9418126a0.tar.gz
historical-5fe804ccc0da27f1c4cde1435a7519b9418126a0.tar.bz2
historical-5fe804ccc0da27f1c4cde1435a7519b9418126a0.zip
Security bump for buffer underrun. See bug #84479.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild')
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild
new file mode 100644
index 000000000000..0abf2283ea65
--- /dev/null
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.4-r1.ebuild,v 1.1 2005/03/14 19:08:05 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."
+HOMEPAGE="http://ipsec-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64 ~sparc"
+SLOT="0"
+IUSE="selinux"
+DEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-ipsec-tools )"
+
+pkg_setup() {
+ my_KV=`echo ${KV} | cut -f-2 -d "."`
+ if [ ${my_KV} != "2.6" ] ; then
+ echo; eerror "You need a 2.6.x kernel to use the ipsec tools!"; die "You need a 2.6 kernel to use ipsec-tools!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.diff
+ epatch ${FILESDIR}/${PN}-0.5-isakmp-underrun.diff
+}
+
+src_compile() {
+ unset CC
+ ./configure --prefix=/usr --sysconfdir=/etc --with-kernel-headers=/usr/src/linux/include || die
+ sed -e 's:AM_CFLAGS = :AM_CFLAGS = -include /usr/src/linux/include/linux/compiler.h :' -i src/setkey/Makefile || die
+ sed -e 's:CPPFLAGS=:CPPFLAGS = -include /usr/src/linux/include/linux/compiler.h :' -i src/racoon/Makefile || die
+ sed -e 's:va_copy:__va_copy:g' -i src/racoon/plog.c || die # GCC 2 Fix
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ rm ${D}/usr/bin
+ dosbin src/racoon/racoon
+ insinto /etc && doins ${FILESDIR}/ipsec.conf.sample
+ insinto /etc/conf.d && newins ${FILESDIR}/racoon.conf.d racoon
+ exeinto /etc/init.d && newexe ${FILESDIR}/racoon.init.d racoon
+
+ dodoc ChangeLog README NEWS
+ dodoc ${S}/src/racoon/samples/racoon.conf.sample*
+}