summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-26 08:37:55 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-26 08:37:55 +0000
commit917cef38f7a44c41c47ced94d4a99089d9a7f52a (patch)
treea58c34b6328ce46d198789ce6b3b182c9488c001 /net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild
parent-sparc. (diff)
downloadhistorical-917cef38f7a44c41c47ced94d4a99089d9a7f52a.tar.gz
historical-917cef38f7a44c41c47ced94d4a99089d9a7f52a.tar.bz2
historical-917cef38f7a44c41c47ced94d4a99089d9a7f52a.zip
initial import as per bug #62491
Diffstat (limited to 'net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild')
-rw-r--r--net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild b/net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild
new file mode 100644
index 000000000000..702383940994
--- /dev/null
+++ b/net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/pftpfxp-0.11.4.6.ebuild,v 1.1 2004/11/26 08:37:54 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The powerful curses-based ftp/fxp client, mew edition"
+HOMEPAGE="http://pftpmew.tanesha.net"
+SRC_URI="http://tanesha.net/bigmess/pftpfxp-v0.11.4mew6.tgz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="crypt"
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )"
+S=${WORKDIR}/pftpfxp-mew
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.4.fix
+ sed -i -e "s/^CPP=.*/CPP=$(tc-getCXX)/" \
+ -e "s:^CPPF=.*:CPPF=\"-Wall -D_REENTRANT -I../include ${CFLAGS}\":" \
+ configure
+}
+
+src_compile() {
+ cd ${S}
+ #note: not a propper autoconf
+ ./configure || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin pftp
+ dodoc .pftp/config .pftp/keymap README.MEW old/*
+ cd ${WORKDIR}
+ mv irssi mIRC-mew pftpfxp-autoconnect ${DOCDESTTREE}
+}
+
+pkg_postinst() {
+ einfo "In order to use pftp-mew you need to create these files:"
+ einfo " ~/.pftp/config"
+ einfo " ~/.pftp/keymap"
+ einfo "Refer to the examples in ${DOCDESTTREE} for more information."
+}