summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:16:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:16:50 +0000
commit41ccd562f98b2d8ab65d8d218861e8c22f679cc1 (patch)
treed9c957cc033da840b78c1fa828f17e68b60e9546 /net-ftp
parentshadow password fix (diff)
downloadhistorical-41ccd562f98b2d8ab65d8d218861e8c22f679cc1.tar.gz
historical-41ccd562f98b2d8ab65d8d218861e8c22f679cc1.tar.bz2
historical-41ccd562f98b2d8ab65d8d218861e8c22f679cc1.zip
shadow password fix
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpd/Manifest5
-rw-r--r--net-ftp/ftpd/files/digest-ftpd-0.17-r11
-rw-r--r--net-ftp/ftpd/files/ftpd-0.17-shadowfix.patch30
-rw-r--r--net-ftp/ftpd/ftpd-0.17-r1.ebuild57
4 files changed, 91 insertions, 2 deletions
diff --git a/net-ftp/ftpd/Manifest b/net-ftp/ftpd/Manifest
index 0185729e40fb..6a3ec7127b6d 100644
--- a/net-ftp/ftpd/Manifest
+++ b/net-ftp/ftpd/Manifest
@@ -1,5 +1,6 @@
-MD5 e6d9b81eb82f7303ae61925083c66159 ftpd-0.17-r1.ebuild 1509
-MD5 abf8f9bb708d75e0a41a5c2952543d08 ChangeLog 1067
+MD5 896266bf5745aa5e2aadfcd8e30b956a ftpd-0.17-r1.ebuild 1514
+MD5 46d5c0286f439004e719ce71f3878668 ChangeLog 1348
+MD5 47bae7b7c544c23d1f1bdbe68c614156 ftpd-0.17.ebuild 1466
MD5 1185c6db5ae646d809d0c757f02d8e35 files/digest-ftpd-0.17 66
MD5 7e1217f2de231dda2c8e842a7d7dfb7b files/ftpd-0.17-shadowfix.patch 895
MD5 e9e77d723b87be9b3f8b6bff9deb87c3 files/ftp.xinetd 219
diff --git a/net-ftp/ftpd/files/digest-ftpd-0.17-r1 b/net-ftp/ftpd/files/digest-ftpd-0.17-r1
new file mode 100644
index 000000000000..909d577cfb10
--- /dev/null
+++ b/net-ftp/ftpd/files/digest-ftpd-0.17-r1
@@ -0,0 +1 @@
+MD5 f5f491564812db5d8783daa538c49186 linux-ftpd-0.17.tar.gz 46763
diff --git a/net-ftp/ftpd/files/ftpd-0.17-shadowfix.patch b/net-ftp/ftpd/files/ftpd-0.17-shadowfix.patch
new file mode 100644
index 000000000000..1287a6fcd06a
--- /dev/null
+++ b/net-ftp/ftpd/files/ftpd-0.17-shadowfix.patch
@@ -0,0 +1,30 @@
+diff -Naur linux-ftpd-0.17/ftpd/Makefile linux-ftpd-0.17-patched/ftpd/Makefile
+--- linux-ftpd-0.17/ftpd/Makefile 1999-12-12 19:04:58.000000000 +0100
++++ linux-ftpd-0.17-patched/ftpd/Makefile 2003-04-06 11:52:17.000000000 +0200
+@@ -19,7 +19,11 @@
+ all: ftpd
+
+ %.o: %.c
++ ifdef USE_SHADOW
++ $(CC) $(CFLAGS) -DUSE_SHADOW -DHASSETPROCTITLE $< -c
++ else
+ $(CC) $(CFLAGS) -DHASSETPROCTITLE $< -c
++ endif
+
+ ftpcmd.c: %.c: %.y
+ $(YACC) $<
+diff -Naur linux-ftpd-0.17/support/Makefile linux-ftpd-0.17-patched/support/Makefile
+--- linux-ftpd-0.17/support/Makefile 1999-08-01 00:05:52.000000000 +0200
++++ linux-ftpd-0.17-patched/support/Makefile 2003-04-06 11:54:50.000000000 +0200
+@@ -5,7 +5,11 @@
+ all: libsupport.a
+
+ %.o: %.c
++ ifdef USE_SHADOW
++ $(CC) $(CFLAGS) -DUSE_SHADOW -DHASSETPROCTITLE $< -c
++ else
+ $(CC) $(CFLAGS) -DHASSETPROCTITLE $< -c
++ endif
+
+ libsupport.a: $(OBJS)
+ ar -cruv $@ $^
diff --git a/net-ftp/ftpd/ftpd-0.17-r1.ebuild b/net-ftp/ftpd/ftpd-0.17-r1.ebuild
new file mode 100644
index 000000000000..51abe27aab5d
--- /dev/null
+++ b/net-ftp/ftpd/ftpd-0.17-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17-r1.ebuild,v 1.1 2003/06/07 08:16:47 seemant Exp $
+
+inherit eutils
+
+IUSE="ssl"
+
+S=${WORKDIR}/linux-${P}
+DESCRIPTION="The netkit FTP server with optional SSL support"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/linux-${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ virtual/inetd"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if [ "`use ssl`" ]; then
+ epatch ${FILESDIR}/ssl.diff.gz
+ epatch ${FILESDIR}/${P}-shadowfix.patch
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ cp MCONFIG MCONFIG.orig
+ sed -e "s:-pipe -O2:${CFLAGS}:" MCONFIG.orig > MCONFIG
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ dobin ftpd/ftpd
+ doman ftpd/ftpd.8
+ dodoc README ChangeLog
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/ftp.xinetd ftp
+}
+
+pkg_postinst() {
+ einfo "In order to start the server with SSL support"
+ einfo "You need to create a certificate and place it"
+ einfo "in SSLCERTDIR..."
+ einfo "<=openssl-0.9.6g - SSLCERTDIR=/usr/lib/ssl/certs"
+ einfo ">=openssl-0.9.6g-r1 - SSLCERTDIR=/etc/ssl/certs"
+ einfo ""
+ einfo "cd SSLCERTDIR"
+ einfo "openssl req -new -x509 -nodes -out ftpd.pem -keyout ftpd.pem"
+ einfo ""
+}