summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-16 04:54:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-16 04:54:32 +0000
commit48ac91154e57ad28b84fc86f1f98bb5f75aab35d (patch)
treea32ddddb9ce2e2c85cae07015ca320385c43a492 /net-ftp
parentadded keywords (diff)
downloadhistorical-48ac91154e57ad28b84fc86f1f98bb5f75aab35d.tar.gz
historical-48ac91154e57ad28b84fc86f1f98bb5f75aab35d.tar.bz2
historical-48ac91154e57ad28b84fc86f1f98bb5f75aab35d.zip
ppc tagging
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftp/ftp-0.17-r1.ebuild36
-rw-r--r--net-ftp/ncftp/files/digest-ncftp-3.1.21
-rw-r--r--net-ftp/ncftp/ncftp-3.1.2.ebuild27
-rw-r--r--net-ftp/ncftp/ncftp-3.1.3.ebuild6
-rw-r--r--net-ftp/ncftp/ncftp-3.1.4.ebuild6
-rw-r--r--net-ftp/proftpd/proftpd-1.2.5-r1.ebuild4
6 files changed, 29 insertions, 51 deletions
diff --git a/net-ftp/ftp/ftp-0.17-r1.ebuild b/net-ftp/ftp/ftp-0.17-r1.ebuild
index 3fa505ab79b7..1e72a30ffcf8 100644
--- a/net-ftp/ftp/ftp-0.17-r1.ebuild
+++ b/net-ftp/ftp/ftp-0.17-r1.ebuild
@@ -1,28 +1,30 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.5 2002/07/11 06:30:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.6 2002/07/16 04:54:32 seemant Exp $
-A=netkit-${P}.tar.gz
-S=${WORKDIR}/netkit-${P}
+MY_P=netkit-${P}
+S=${WORKDIR}/netkit-${MY_P}
DESCRIPTION="Standard Linux FTP client"
-SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${A}"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
-src_compile() {
-
- try ./configure --prefix=/usr
- cp MCONFIG MCONFIG.orig
- sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
- try make
-}
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc"
-src_install() {
- into /usr
- dobin ftp/ftp
- doman ftp/ftp.1 ftp/netrc.5
- dodoc ChangeLog README BUGS
+src_compile() {
+
+ ./configure --prefix=/usr || die
+ cp MCONFIG MCONFIG.orig
+ sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
+ make || die
}
-
+src_install() {
+ into /usr
+ dobin ftp/ftp
+ doman ftp/ftp.1 ftp/netrc.5
+ dodoc ChangeLog README BUGS
+}
diff --git a/net-ftp/ncftp/files/digest-ncftp-3.1.2 b/net-ftp/ncftp/files/digest-ncftp-3.1.2
deleted file mode 100644
index da30efa9dd3d..000000000000
--- a/net-ftp/ncftp/files/digest-ncftp-3.1.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 53176befbedbc2a094803a42bb7a4d9a ncftp-3.1.2-src.tar.bz2 387013
diff --git a/net-ftp/ncftp/ncftp-3.1.2.ebuild b/net-ftp/ncftp/ncftp-3.1.2.ebuild
deleted file mode 100644
index 4f45c57bad00..000000000000
--- a/net-ftp/ncftp/ncftp-3.1.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.2.ebuild,v 1.2 2002/07/11 06:30:46 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="An extremely configurable ftp client"
-SRC_URI="ftp://ftp.ncftp.com/ncftp/${P}-src.tar.bz2"
-HOMEPAGE="http://www.ncftp.com/"
-SLOT="0"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2"
-
-
-src_compile() {
- ./configure --prefix=/usr --host=${CHOST} \
- --mandir=/usr/share/man || die
-
- emake || die
-}
-
-src_install() {
- dodir /usr/share
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
-
- dodoc CHANGELOG FIREWALL-PROXY-README LICENSE.txt
- dodoc READLINE-README README WHATSNEW-3.0
-}
diff --git a/net-ftp/ncftp/ncftp-3.1.3.ebuild b/net-ftp/ncftp/ncftp-3.1.3.ebuild
index 4eb0ff9baac6..be3b5bad5878 100644
--- a/net-ftp/ncftp/ncftp-3.1.3.ebuild
+++ b/net-ftp/ncftp/ncftp-3.1.3.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.3.ebuild,v 1.2 2002/07/11 06:30:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.3.ebuild,v 1.3 2002/07/16 04:54:32 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An extremely configurable ftp client"
SRC_URI="ftp://ftp.ncftp.com/ncftp/${P}-src.tar.bz2"
HOMEPAGE="http://www.ncftp.com/"
-SLOT="0"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
+
+SLOT="0"
LICENSE="Clarified-Artistic"
+KEYWORDS="x86 ppc"
src_compile() {
./configure --prefix=/usr --host=${CHOST} \
diff --git a/net-ftp/ncftp/ncftp-3.1.4.ebuild b/net-ftp/ncftp/ncftp-3.1.4.ebuild
index f964c3cecfdc..f9f75379991d 100644
--- a/net-ftp/ncftp/ncftp-3.1.4.ebuild
+++ b/net-ftp/ncftp/ncftp-3.1.4.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.4.ebuild,v 1.2 2002/07/11 06:30:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.4.ebuild,v 1.3 2002/07/16 04:54:32 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An extremely configurable ftp client"
SRC_URI="ftp://ftp.ncftp.com/ncftp/${P}-src.tar.bz2"
HOMEPAGE="http://www.ncftp.com/"
-SLOT="0"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
+
+SLOT="0"
LICENSE="Clarified-Artistic"
+KEYWORDS="x86 ppc"
src_compile() {
./configure --prefix=/usr --host=${CHOST} \
diff --git a/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild b/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild
index 07bad8fe5691..69d2f8e7a1e1 100644
--- a/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild
+++ b/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild,v 1.3 2002/07/09 22:21:17 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.5-r1.ebuild,v 1.4 2002/07/16 04:54:32 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An advanced and very configurable FTP server"
SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P}.tar.bz2"
HOMEPAGE="http://www.proftpd.net/"
-KEYWORDS="x86"
+KEYWORDS="x86 ppc"
SLOT="0"
LICENSE="GPL-2"