summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-09 18:07:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-09 18:07:07 +0000
commit70b90ba01633466c3550d85b6d71d2b409509686 (patch)
tree3135d250d1c3c180ab46d95383a43f58806ce623 /net-im/kmess/kmess-2.0.6.2.ebuild
parentUpdate comments about extensions. (diff)
downloadhistorical-70b90ba01633466c3550d85b6d71d2b409509686.tar.gz
historical-70b90ba01633466c3550d85b6d71d2b409509686.tar.bz2
historical-70b90ba01633466c3550d85b6d71d2b409509686.zip
Version bump. Bug #415273
Package-Manager: portage-2.1.10.57/cvs/Linux x86_64
Diffstat (limited to 'net-im/kmess/kmess-2.0.6.2.ebuild')
-rw-r--r--net-im/kmess/kmess-2.0.6.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-im/kmess/kmess-2.0.6.2.ebuild b/net-im/kmess/kmess-2.0.6.2.ebuild
new file mode 100644
index 000000000000..381ee48943a9
--- /dev/null
+++ b/net-im/kmess/kmess-2.0.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-2.0.6.2.ebuild,v 1.1 2012/05/09 18:07:07 hwoarang Exp $
+
+EAPI=3
+
+KDE_LINGUAS="ar ca de el es et fi fr gl hu it ja nl pt_BR ru sk tr zh_CN zh_TW"
+inherit kde4-base
+
+MY_P="${P/_/}"
+
+DESCRIPTION="KMess is an alternative MSN Messenger chat client for Linux"
+HOMEPAGE="http://www.kmess.org"
+SRC_URI="mirror://sourceforge/${PN}/Latest%20versions/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug gif konqueror libnotify xscreensaver"
+RESTRICT="test"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ gif? ( media-libs/giflib )
+ konqueror? ( $(add_kdebase_dep libkonq) )
+ libnotify? ( $(add_kdebase_dep knotify) )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+DEPEND="${COMMONDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ xscreensaver? ( x11-proto/scrnsaverproto )
+"
+RDEPEND="${COMMONDEPEND}
+ konqueror? ( $(add_kdebase_dep konqueror) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gif GIF)
+ $(cmake-utils_use_with konqueror LibKonq)
+ $(cmake-utils_use_want xscreensaver XSCREENSAVER)"
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "KMess can use the following optional packages:"
+ elog "- www-plugins/adobe-flash provides support for winks"
+ echo
+}